Question Cant play mafia 3 on dedicated gpu

May 19, 2019
1
0
10
0
Hi,
I recently installed mafia 3 and while playing it is so slow (10-15 fps). When i checked the task manager it shows that the game is using gpu 0 (integrated). I changed both launcher.exe and mafia 3.exe to run on nvidia gpu (gpu 1). But it did not help. Is there a way to to force mafia 3 to run on dedicated gpu??
My specs:
Core i7 6700 hq
Nvidia 960m
16 gb ram

Thanks
 

Metal Messiah.

Commendable
Mar 28, 2019
1,878
388
1,790
52
What's the model number of your LAPTOP ? Have you also tried looking into the BIOS settings, to disable the integrated graphics ?

Some newer laptops have a built-in switch mechanism. If you're simply surfing the internet, watching internet videos etc., the computer will use INTEL HD graphics chip, because it uses less power which leads to longer battery life.

When you're gaming, your laptop should automatically switch to your dedicated GPU, IMO (Nvidia 960m ). Anyways, give this a try:

Go to NVIDIA Control Panel 3D Settings->Manage 3D Settings Tab, under Global settings and select high performance Nvidia processor, under the "preferred graphics processor" option.

IF that doesn't work, then try this. Go to Control Panel > Hardware/Device Manager > Display Adapters > right click Intel HD Graphics and click on Disable
 
Last edited:

Gmoney06ss

Reputable
Jul 3, 2015
557
78
5,090
11
Mafia 3 is a very bad optimized game though.
Yes, that it is. But it still should be using the dedicated gfx vs integrated.

Does this happen on other games, or just mafia 3?

Like stated above, try and completely disable the integrated and see if that works. And if you do get it running, I'd recommend not maxing the settings. It is poorly optimized like lux mentioned, and tends to stutter in high settings for me.
 

ASK THE COMMUNITY

TRENDING THREADS