Question Cant plug GPU to PCIE

Aug 25, 2019
4
0
10
0
I just bought an asus rog 2070 for my son and cannot plug it into any PCIE. Nor my pc and the kids pc. The right side, where the lock is, it connects well, but the left side doesent. Tried 4 slots, 2 on my pc and 2 on the childs, without any success. Also tried taking off the motherboard, and lift up the fixing screws. But the result the same. Do you guys have any idea?
 
The GPU should work on those motherboards. Did you properly plug all the PCI-E cables to the GPU as well ? Do you have the latest system BIOS ?

IF not, then please update the BIOS, and check the card again. Latest 2018/2019 updates are available.:

https://www.msi.com/Motherboard/support/Z170A-GAMING-PRO-CARBON

https://www.gigabyte.com/in/Motherboard/Z370-HD3P-rev-10/support#support-dl-bios

Clear and reset all the CMOS/BIOS settings as well, if need be. Also, did you insert the GPU on the primary PCI-Express x16 slot ?
 
Last edited:
Reactions: MoreCola

Wolfshadw

Titan
Moderator
I have tried in theese PCs:
  • Msi Z170A Gaming pro carbon motherboard, intel i5-6500 with Coolermaster 500W PSU.
  • Gigabyte Z370 HD3P motherboard, intel i7-8700k with Corsair CX600 (600W) PSU.
Could you please provide an image or two of what you're looking at when you say the left side doesn't fit? You will need to use a third party image hosting site like tinypic or imgur and then post the image links here.

-Wolf sends
 

Wolfshadw

Titan
Moderator
Make sure there are no obstructions where the two prongs of the mounting brackets slip between the case and the motherboard:



The top edges of the mounting brackets should be flush with where the screws hold the card in place. Also make sure there is nothing in the expansion slot. You should be able to push it down with a minimal amount of pressure.

-Wolf sends
 
Reactions: MoreCola

ASK THE COMMUNITY