Question Cant recover bios Asus Rog Strix x570

Mar 29, 2020
1
0
10
0
So, I finished my build last week. It was working save a few weird issues and some needed canker management.

I have the ml360r master cooler AIO heat sink, which comes with an argb controller, and I couldn't quite get it wired in nicely due to cable length. Everything was fine until I swapped the cables and wired it into the argb-in.

Then I got stuck where every time I rebooted I would get stuck in bios. Eventually I figured out I was missing some PCI drivers. Fixed that, and instead of crashing and getting stuck it just would randomly get BSOD. I cant even remember where I got the idea, but I got to wondering if I needed to update my bios, I'd fixed everything else. I was out of ideas and rebooting every 2 hours is fundamentally unacceptable.

Asus has an update by internet so I tried that. It grabbed the file (version seemed right - 1407) about halfway through things flickered and I've been stuck at the motherboard splash screen.

Thingsive tried:
- USB with bios and hoping for EZ recovery. No luck.
- hitting the reset pins with metal (while computer was unplugged.
- taking battery out and waiting 30 seconds.

I seem unable to recover the bios, but I'm willing to consider I'm doing it wrong.
 

ASK THE COMMUNITY

TRENDING THREADS