Can't Reinstall Drivers! (New PC with an old brain)

Weeaboo Willy

Prominent
Jun 16, 2017
6
0
510
0
So I recently built a new PC for Christmas, and so far I've been able to get everything to work pretty fine and dandy. Drivers were up to date, temps were cool, and I've already played some pretty killer games well on it. Well, I tried uninstalling my GPU drivers to install some older drivers that are known to work better with Destiny 2 (The only game giving me weird FPS drops). Well, since the uninstall I haven't been able to install any of the older drivers, or even reinstall the drivers I was ALREADY using before, (417.35 I think). Every time I try to install a driver, I just get the message "The Graphics Driver Could Not Find Compatible Graphics Hardware," from the installer.

I've already done some digging on some other threads about the issue, and everyone else I've seen having this issue is someone with a GPU they haven't gotten to even work for sure yet. The concerning thing is, I've already gotten this GPU to work with installed drivers but I can't get it to do it again, after I uninstalled the drivers.

Also, here's another complication... The main hard drive in this PC is an HDD moved over from my old prebuilt (I factory resetted it, but the PC still thinks its a shoddy ASUS prebuilt with plenty of unnecessary firmware.) And to top it off, its still running Windows 8.1 and the PC constantly lets me know I need a different OS.

All I really want right now is to have my PC recognize my GPU again and install a graphics driver again so I can play games, because as of right now I cant even find my GPU in the device manager.

tl;dr- new pc, old HDD with bloatware and dead os that doesn't work well with hardware, i need to install drivers and my pc wont even recognize my gpu anymore because i uninstalled drivers i used to have

Also here's my specs in case anyone needs them.

Mobo: MSI X470 GAMING PLUS
CPU: Ryzen 5 1600
GPU: MSI GTX 1070 8GB
RAM: Ripjaws V 2400 DDR4
PSU: Corsair RM 550X PLUS Gold
Storage: TOSHIBA DT01ACA100 (The one from my prebuilt) and WDC WD10EZEX-08WN4AO (New one, also the slave drive)
Also, I plan on getting an SSD soon too, don't worry about the 2 HDD thing going on (yes its a thorn in my side HDD's are slow.)

Any and all help would be greatly appreciated, and sorry for such a loaded thread!

 

Weeaboo Willy

Prominent
Jun 16, 2017
6
0
510
0


Yeah, I honestly just wanted to play some games on the PC while I was still on break and it DID work out pretty well, I just can't get it to play stuff now now that I've uninstalled the GPU drivers (obviously). Also I'm definitely gonna be doing some reformatting/file moving around once I get an SSD and Windows 10, because old 8.1 on a bloated HDD definitely isn't cutting it either lol.
 

ASK THE COMMUNITY