Question Can't set RAM speed higher than 2133MHz - X570, Ryzen 5000

Mar 18, 2021
2
0
10
0
I hope someone can help me out.

I just upgraded to a Ryzen 7 5800x + Crosshair VIII Dark Hero from an i7 7700k + Strix Z270F.

I am unable to even get into Windows at any memory clock higher than 2133MHz, at 2400MHz the login screen may load but my PC will crash immediately after typing my password and go to the Windows recovery screen.

The memory I am using is G Skill Trident Z RGB 3200MHz CAS 16, 4x 8GB modules. It was perfectly capable of reaching 3200MHz on my old intel system, so the modules themselves are not faulty.

I have tried DOCP auto settings, adjusting the speed manually and a few other adjustments but with no luck. My PC absolutely will not post at 3200MHz memory clock. If I do try 3200MHz, I get error code 36 on the motherboards display and my only option is to clear the CMOS.

My PC is perfectly stable, however, if I set the DRAM voltage to 1.35 volts (the official voltage rating for Trident Z RAM) but leave the memory clock at 2133MHz. Even the smallest possible increment in memory speed prevents being able to get into Windows.

If anyone has any clue on what I could possibly try, or if my RAM is just incompatible with X570 and Ryzen 5000, please let me know.

Many thanks, Callum

Update: I've tried all of my modules 1 at a time, as well as identically specced Corsair Vengeance. 1 module alone would not exceed 2133MHz, the other 5 I tried are all perfectly functional at 3200MHz, with Windows booting stably. Is my only option now to discard the semi functional Trident module and purchase a replacement? If anyone knows if there's anything I can do about it, that would be very helpful.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS