Question Cant tell if my PSU or GPU is causing issues

Nov 28, 2020
1
0
10
0
Hey guys, recently had a problem with my PC and I've been trying to do some research and find out what the issue is but I can't seem to figure it out. I am hoping someone here will be able to help me. Basically I built the PC close to a year ago now and it is my first build. Specs are:
Nvidia gtx 1060 6gb GPU
amd ryzen 5 3600 CPU
16 gb ddr4 (2x8gb) hyper x fury 3200
Cooler master mwe gold 550w PSU
Asus b450 M-A motherboard
Basically the PC had been running like a dream up until about 2 weeks ago when every now and then the PC would just completely shut off without warning while I was in game and start itself back up. This happened maybe 4-5 times. Then just yesterday it did the shut down however, this time it did not restart back up. I tried turning it back on, nothing. The light on the motherboard stays on when the PC has power but nothing else will go when I push the power button. The curious thing is that when I take the graphics card out, the PC will start up but the screens will not connect so I am unsure if it loads into the bios. When i plug the GPU back in, the power button goes back to doing nothing. I am thinking it is either a problem with the PSU or GPU but I have no other computers or spare parts to do some testing with. I am wondering if anyone has any idea what might be happening or has had a similar issue before I start to purchase new parts to troubleshoot with. Thanks in advance guys!
 

ASK THE COMMUNITY

TRENDING THREADS