Can't touch second card in MSI afterburner.

Jet Slicker

Dec 21, 2010
Hi, I recently crossfired an MSI 5830 with an MSI 5850 on my Asus M4A89gtd pro/USB3 motherboard. Both of the cards are twin frozr II.

Before the crossfire I had the 5830 single.

The motherboard has 2 pci-e slots, and the bottom one is the master card slot.
So, at first, I put the 5850 in the master card slot because it was the more powerful card.
I booted the computer up and everything worked fine, crossfire elabled and it was stable. So I went to MSI afterburner to start overclocking.

I can do whatever I want to the 5850, change volts, core clock, memory clock, fan.
But when I go to the settings and switch to the 5830 to overclock it, I can't do a single thing to it without the computer freezing.

I've tried many different drivers and none of them made a difference.
I've discovered though that if I disable the "Sync settings for similar graphics processors" option, I can change the voltage and fan options, but they don't do anything.
If I adjust the core clock or the memory clock though, it freezes.

So, I switched the cards around, and put the 5830 in the master card slot, and the 5850 in the other slot.
The results are that I can overclock both cards with no freezing.

Now, I don't know if this is how I HAVE to do it, but I would prefer the 5850 to be the master card so it does most of the work. Maybe that won't work though because the 5850 is faster than the 5830 and thus it has to be the 2nd card.

*Note* Even though the 5830 is in the master card slot, MSI afterburner still recognises it as the master card or "GPU-1".

I've also stopped CCC from starting when windows boots up, and I've also disabled ULPS.

So, can anybody please tell me if there is a way to have the 5850 be in the master card slot?
Or, do I have to use the 5830 for that?

This could also be a hardware/motherboard thing and not MSI afterburner.

One more thing, after a computer reboot, the first time you open the settings in afterburner, it crashes and said it stopped working.
So I have to click on the desktop icon to open it again, but after that I can open the setting however much I want without a problem, it's just after you reboot it does that once.
I don't know if this helps or not but I think it's worth mentioning.

I'm using afterburner v2.1.0 beta 5 and the newest, 10.12 drivers.

Can anybody please help me?

I suspect you might be wanting more than what the Crossfire software utility is capable of, quite simply: the ability to OC different cards independently, *and* have the software/hardware/firmware use them for optimum balance in different processing ratios...