[SOLVED] Can't 'Turbo Boost' my Intel I-8250U

Sep 12, 2021
3
1
10
0
Hello, I've recently learned that I can use a specific boost from Intel for my CPU, and I checked everywhere but I've found no way to make it work. My BIOS is barebones and has no CPU options to enable or disable, the Turbo Boost Monitor 2.6 says my CPU isn't compatible (although intel's own website says it is), and Intel Turbo Boost Max, when I try to launch it, gives me an error message saying: "ITBM Driver not found. Exiting application." I'm at a complete loss at how to make it work.

 

uWebb429

Notable
May 22, 2020
264
96
890
31
Turbo boost is automatically enabled. You do not need any special drivers for it to work. Try monitoring your computer with CPU-Z. Run a single threaded task and it should show you if turbo boost is working or not.
 

uWebb429

Notable
May 22, 2020
264
96
890
31
Turbo boost is automatically enabled. You do not need any special drivers for it to work. Try monitoring your computer with CPU-Z. Run a single threaded task and it should show you if turbo boost is working or not.
 
Sep 12, 2021
3
1
10
0
Turbo boost is automatically enabled. You do not need any special drivers for it to work. Try monitoring your computer with CPU-Z. Run a single threaded task and it should show you if turbo boost is working or not.
Thank you for the reply! On CPU-Z I couldn't manage to figure out where to see, so I used Task Manager and ran a (presumably cpu-intense) Blender particle animation, which the program uses cpu power for due to not being compatible with my gpu. On Task manager it never went above 1.58Ghz. I'm not sure if this is conclusive, but I'm unsure what tasks I can run that are single-threaded or how to check it on cpu-z.

Edit: I checked on CPU-Z. It hasn't gone above 1595.96Mhz.
 
Last edited:

Jacob 51

Upstanding
Dec 31, 2020
515
19
385
0
Thank you for the reply! On CPU-Z I couldn't manage to figure out where to see, so I used Task Manager and ran a (presumably cpu-intense) Blender particle animation, which the program uses cpu power for due to not being compatible with my gpu. On Task manager it never went above 1.58Ghz. I'm not sure if this is conclusive, but I'm unsure what tasks I can run that are single-threaded or how to check it on cpu-z.
Go to power & sleep settings and change the minimum processor state and maximum to 100%.
Then check task manager. It should use more than 1.6 Ghz
 
Sep 12, 2021
3
1
10
0
Go to power & sleep settings and change the minimum processor state and maximum to 100%.
Then check task manager. It should use more than 1.6 Ghz
Thank you for the tip, but I did it and it remains the same. I changed both on battery and plugged in, ran blender and still didn't crack 1.6Ghz on neither CPU-Z nor Task Manager.
Edit: Just in case, ran a game too. The Usage goes up in % but the Mhz / Ghz remains the same.

Edit 2: I used CPU-Z's stress & bench with a single thread. Still won't trigger turbo boost.

Edit 3: It has triggered it now. I apologize for the thread but it turns out it is on, it was only I wasn't testing it properly. Thank you all!
 
Last edited:
Reactions: Jacob 51

ASK THE COMMUNITY