Question Can't update BIOS: EZ Flash 2 leads to a blackscreen

Jul 31, 2022
10
0
10
0
Hello. Here are my specs:
(nothing's overclocked)
CPU: Intel i3 4150 3.50GHz
GPU: GTX 750 Ti, ASUS version
MOBO: ASUS H81M-K
PSU: Floston, 500W
RAM: 2* 8GB 1600MHz, Teamgroup
Drive: 1TB HDD SATA3 7.2k RPM, Seagate Barracuda, read further.
BIOS Version: 0804 x64
BIOS Date: 05/13/2014 (I know, old)
ME Version: 9.0.30.1482
South Bridge Stepping: 05/C2

I'm trying to update the BIOS of my ASUS H81M-K. Currently, it has BIOS version 0804, from 2014, whilst the newest version is 3604 from 2021.
I've formatted an USB drive to FAT32, and added onto it the BIOS update file. However, when I'm trying to access EZ Flash 2 the screen just goes black, and that's it.

Any ideas?
Thanks in advance.
 
Hello. Here are my specs:
(nothing's overclocked)
CPU: Intel i3 4150 3.50GHz
GPU: GTX 750 Ti, ASUS version
MOBO: ASUS H81M-K
PSU: Floston, 500W
RAM: 2* 8GB 1600MHz, Teamgroup
Drive: 1TB HDD SATA3 7.2k RPM, Seagate Barracuda, read further.
BIOS Version: 0804 x64
BIOS Date: 05/13/2014 (I know, old)
ME Version: 9.0.30.1482
South Bridge Stepping: 05/C2

I'm trying to update the BIOS of my ASUS H81M-K. Currently, it has BIOS version 0804, from 2014, whilst the newest version is 3604 from 2021.
I've formatted an USB drive to FAT32, and added onto it the BIOS update file. However, when I'm trying to access EZ Flash 2 the screen just goes black, and that's it.

Any ideas?
Thanks in advance.
Can you post a video you record on a phone or something to give us a example I'm fairly certain I can picture it but it is easier to help with a video of the issue when it comes to things like this
 
Hello. Here are my specs:
(nothing's overclocked)
CPU: Intel i3 4150 3.50GHz
GPU: GTX 750 Ti, ASUS version
MOBO: ASUS H81M-K
PSU: Floston, 500W
RAM: 2* 8GB 1600MHz, Teamgroup
Drive: 1TB HDD SATA3 7.2k RPM, Seagate Barracuda, read further.
BIOS Version: 0804 x64
BIOS Date: 05/13/2014 (I know, old)
ME Version: 9.0.30.1482
South Bridge Stepping: 05/C2

I'm trying to update the BIOS of my ASUS H81M-K. Currently, it has BIOS version 0804, from 2014, whilst the newest version is 3604 from 2021.
I've formatted an USB drive to FAT32, and added onto it the BIOS update file. However, when I'm trying to access EZ Flash 2 the screen just goes black, and that's it.

Any ideas?
Thanks in advance.
You will need to use imgur.com to post the video copy the link they give you for it and post it here
 
Jul 31, 2022
10
0
10
0
Can you post a video you record on a phone or something to give us a example I'm fairly certain I can picture it but it is easier to help with a video of the issue when it comes to things like this
Sure thing, here it is:
View: https://imgur.com/a/u2JugzE

There's no delay between me hitting ENTER and the screen going black.
I've also tried to let it sit like this, as if it were loading quite slowly, but 30+ minutes later the screen was still black.
 
Sure thing, here it is:
View: https://imgur.com/a/u2JugzE

There's no delay between me hitting ENTER and the screen going black.
I've also tried to let it sit like this, as if it were loading quite slowly, but 30+ minutes later the screen was still black.
Have you tried to clear your cmos yet? It seems like it's kinda acting like there to much happening for the system to think right.

With the psu unplugged remove the lithium battery from the Mobo with both removed hold the power button on the case for 30s x2s see if this corrects the issue if not I think I may know what it could be however unlikely
 
Jul 31, 2022
10
0
10
0
Have you tried to clear your cmos yet? It seems like it's kinda acting like there to much happening for the system to think right.

With the psu unplugged remove the lithium battery from the Mobo with both removed hold the power button on the case for 30s x2s see if this corrects the issue if not I think I may know what it could be however unlikely
Did this twice, made no difference.
 
Did this twice, made no difference.
Ok so what I would recommend at this point which saddly from my knowledge is the last thing to try, remove all memory minus one stick of ram, remove all storage devices "all of them including the bios update USB you don't have to take them out out, "just remove their sata connection to the Mobo. And unplug the m.2's if any... Try to enter easy flash if it still black screens sounds like the easy flash tool corrupted if this works and it loads into the flash software, either one of you SATA or m.2 drives have a issue, or the bios update USB has a massive problem and needs to be double checked
 
Jul 31, 2022
10
0
10
0
Ok so what I would recommend at this point which saddly from my knowledge is the last thing to try, remove all memory minus one stick of ram, remove all storage devices "all of them including the bios update USB you don't have to take them out out, "just remove their sata connection to the Mobo. And unplug the m.2's if any... Try to enter easy flash if it still black screens sounds like the easy flash tool corrupted if this works and it loads into the flash software, either one of you SATA or m.2 drives have a issue, or the bios update USB has a massive problem and needs to be double checked
I've tried that too, unfortunately. I recorded the video having nothing plugged in, except the USB: no HDD or SATA connection, no M.2, only one stick of ram (though I've tried on different sticks or RAM as well, and also with 2 sticks inserted.)
The problem persists if I remove the USB too, so it's not cause by the USB stick. No matter the configuration, the EZ Flash thing leads to a blackscreen.
 
I've tried that too, unfortunately. I recorded the video having nothing plugged in, except the USB: no HDD or SATA connection, no M.2, only one stick of ram (though I've tried on different sticks or RAM as well, and also with 2 sticks inserted.)
The problem persists if I remove the USB too, so it's not cause by the USB stick. No matter the configuration, the EZ Flash thing leads to a blackscreen.
Give me one moment to do a little research on the board I maybe able to find a work around that hopefully will fix flash tool as well
 
I've tried that too, unfortunately. I recorded the video having nothing plugged in, except the USB: no HDD or SATA connection, no M.2, only one stick of ram (though I've tried on different sticks or RAM as well, and also with 2 sticks inserted.)
The problem persists if I remove the USB too, so it's not cause by the USB stick. No matter the configuration, the EZ Flash thing leads to a blackscreen.
I'm not sure if this is like Asus armoury creat or not but if it is, you should be able to use this to update the bios and bibass the ez flash... You would just need to install this and tell it to update the bios

https://dlcdnets.asus.com/pub/ASUS/misc/utils/AOHelp_Win7-8-81-10_V1225233.zip
 
I've tried that too, unfortunately. I recorded the video having nothing plugged in, except the USB: no HDD or SATA connection, no M.2, only one stick of ram (though I've tried on different sticks or RAM as well, and also with 2 sticks inserted.)
The problem persists if I remove the USB too, so it's not cause by the USB stick. No matter the configuration, the EZ Flash thing leads to a blackscreen.
Were you able to figure it out
 
Jul 31, 2022
10
0
10
0
I'm not sure if this is like Asus armoury creat or not but if it is, you should be able to use this to update the bios and bibass the ez flash... You would just need to install this and tell it to update the bios

https://dlcdnets.asus.com/pub/ASUS/misc/utils/AOHelp_Win7-8-81-10_V1225233.zip
I forgot to mention it, but my PC won't boot into anything. No OS, no nothing. Sadly, I won't be able to use that file.

Were you able to figure it out
Nope, I gave it to a local PC-fixing shop and they couldn't figure anything out either. As of now, the mobo is probably useless. I'll replace it and maybe update this post.
 

ASK THE COMMUNITY

TRENDING THREADS