Question Can't use 4 RAM slots at the same time

Mar 28, 2023
Hello everyone,

I'm having a weird issue, i wanted to upgrade my PC by changing all the RAM (switching from 2x4Gb to 4x8Gb). But it doesn't work, BIOS and windows say only 16Gb.
CPU-Z and RAMMon both show the proper 32Gb on 4 slots.

Here are my specifications :
Motherboard is ASUS P8Z77-V
BIOS version is last (2104)
RAM is DDR3 1600Mz 8Gb x4 from Gskill, brand new, bought all the 4 sticks at the same time
Windows 10 x64 Home edition, up to date

What i've tried :
Updating BIOS to latest : didn't work
Reseating all the bars : didn't work
Removing 2 sticks to just try a pair of slots, then switched the same sticks to the other pair of slots (they are colored on this MB so you can't do mistakes) : worked properly and showed 16Gb in both configurations

I'm a bit lost. I know my hardware is a bit old, but everything is working smoothly. MB specifications says that 32Gb is maximum.
I'm really annoyed that i can't make this work.

I'm taking any advise ! Thanks for your help !

Here are a few screens of the different diagnosis softwares i used :



RAMMon seems to be reporting only half of the installed RAM as the value for physical memory.

Not sure about the format.

= = = =

This motherboard? lx2

[Verify that I found the applicable motherboard manual.]

Double check the supported memory specs via the manual and the QVL (Qualified Vendors List) on the Asus website.

Specifically check the User Manual Memory specs on Page ix.

Then confirm that the installed memory both sticks and current configuration are supported per physically numbered pages 1-7 through and including Page 1-15.

Again, be sure to verify the QVL via the Asus website: there may be some change or update.

The lower half of the RAMMon image is not viewable.

Take another look at the information provided via RAMMon.

For example the note regarding the use of 512 Mb chips presented on Page 1-8.
Mar 28, 2023
Thank you @Ralston18 for your very fast reply !

I've found the proper manual :

Apparently, the configuration i choose isn't in the list. Does this mean that 8Gb x4 isn't supported and won't work on this motherboard ?

I didn't know about those limitations, i should have asked before buying. My fault.

Here's the rest of the RAMMon report, i'm not really sure what i'm supposed to look at.

Thanks a lot for your help !


Unfortunately, the configuration may be unsupported.

And that is not always easy to figure out until after the fact.

Plus it can work but not as expected: less RAM available, slow performance, lots of glitchy problems, strange test results, reported specs that may be misleading, etc...

From the User Manual in the link that you provided (Page 2-6)

This motherboard does not support DIMMs made up of 512Mb (64MB) chips or less
(Memory chip capacity counts in Megabit, 8 Megabit/Mb = 1 Megabyte/MB)


= = = =

RAMMon is reporting timings 11-11-11-28.

Not matching the supported timings listing in Capture D'ecran if I am following correctly.

Go to two or three of the memory manufacturer's websites. Likely there is some configuration tool that allows you to enter motherboard specs and information.

A search is done and the site provides a list of motherboard compatible RAM per the RAM manufacturer's claims.

Still that process can go astray. Key is to discover some consensus where all the RAM specs match.

Details (however messy) matter.