Question Can't use USB device on my motherboard when booting from an USB

Jan 3, 2020
5
0
10
0
I've just built my PC. I can get into SETUP and everything seems to be working fine. I can boot the installation (I tried both 7 and 10) but I cannot use my mouse or keyboard. Basically, the Windows installation media can't detect keyboard and mouse (these worked fine in SETUP).
I tried both, USB 2 and 3 ports.
What could be the problem??

ASUS TUF B450-PRO GAMING
AMD RYZEN 5 2600
MSI Radeon RX 580 ARMOR 8G OC
HyperX Fury Black 16GB
 
Jan 3, 2020
5
0
10
0
If the Windows installation media cannot recognize a keyboard you can't install the system. I am stuck at "select language", so I don't have any system installed.
 

me 1

Distinguished
Oct 2, 2010
846
5
19,065
29
Have you tried removing them exactlly at the language screen and put them back in? Sorry, i know it sounds silly, but i have to ask. :)
If not,
There are some options in the bios you can try to change, starting with usb legacy , but read here for more info:
https://superuser.com/questions/851143/windows-installation-media-cant-detect-keyboard-and-mouse
And if you have trouble going back in the bios with the keyboard after disableing legacy support, you can just reset your cmos battery.

Or last, you can try adding usb drivers to the install media.
 
Jan 3, 2020
5
0
10
0
Have you tried removing them exactlly at the language screen and put them back in? Sorry, i know it sounds silly, but i have to ask. :)
If not,
There are some options in the bios you can try to change, starting with usb legacy , but read here for more info:
https://superuser.com/questions/851143/windows-installation-media-cant-detect-keyboard-and-mouse
And if you have trouble going back in the bios with the keyboard after disableing legacy support, you can just reset your cmos battery.

Or last, you can try adding usb drivers to the install media.
Already tried that :(
I recreated the ISO multiple times.
 

ASK THE COMMUNITY

TRENDING THREADS