Question Capped fps in certain steam games

Apr 20, 2020
9
0
10
0
Hi everyone!

A few days ago I noticed that, in certain steam games(Mudrunner and Mount and Blade: Napoleonic Wars) my fps is capped at 20 fps. No more than that. Also, when I shift+tab, it "unlocks" the fps, but only while I'm shift+tabbed.

Specs: i5 7300HQ
nVidia GTX 1050 4GB
12GB RAM
(the laptop is capable of running these games, as I played them a few months ago with no problems)

Any sugestions on how to fix this? (I've tried reinstalling steam and all steam related things, turning V-sync off and changing game settings, but with no result)
 
Last edited:
Try experimenting with the compatibility settings in the shortcut properties of the game.

The options, via right clicking the shortcut, clicking Properties, then Compatibility tab, are...

Settings
Disable fullscreen optimizations
Run this program as an administrator

(these next 2 are accessed via the Change high DPI settings tab)

Program DPI
(fix scaling problems)

High DPI scaling override
(override high DPI scaling behavior)

These are all commonly used in games that have various W10 compatibility issues. For instance I was getting crashes in GRID 2019, which I'm pretty sure was related to scaling issues, as after crashing the game would launch with an improperly scaled load screen (I'm using 1440p DSR on a 1080p display). Checking Disable fullscreen optimizations seems to have fixed it.

My advice is to apply one setting at a time in the order listed and test after each application. I advise not applying any more settings once a play test shows it's fixed (if it ain't broke, don't fix it rule). If by chance you still have the same problem after trying each setting, revert settings and instead try changing some Steam related settings, like disabling the in-game Steam overlay.
 
Last edited:
Reactions: oofracer
Apr 20, 2020
9
0
10
0
Try experimenting with the compatibility settings in the shortcut properties of the game.

The options, via right clicking the shortcut, clicking Properties, then Compatibility tab, are...

Settings
Disable fullscreen optimizations
Run this program as an administrator

(these next 2 are accessed via the Change high DPI settings tab)

Program DPI
(fix scaling problems)

High DPI scaling override
(override high DPI scaling behavior)

These are all commonly used in games that have various W10 compatibility issues. For instance I was getting crashes in GRID 2019, which I'm pretty sure was related to scaling issues, as after crashing the game would launch with an improperly scaled load screen (I'm using 1440p DSR on a 1080p display). Checking Disable fullscreen optimizations seems to have fixed it.

My advice is to apply one setting at a time in the order listed and test after each application. I advise not applying any more settings once a play test shows it's fixed (if it ain't broke, don't fix it rule). If by chance you still have the same problem after trying each setting, revert settings and instead try changing some Steam related settings, like disabling the in-game Steam overlay.
Thank you for the reply!
I've just tried the settings you listed above, but it didn't changed anything. I only saw an increase of 5-6 fps at first, then it got back at the "normal"(20 fps) framerate
 
Apr 20, 2020
9
0
10
0
Did you try changing Steam settings to disable the overlay?

If none of this is working, I would consider trying an SFC scan.

Follow these instructions exactly. https://support.microsoft.com/en-us/windows/using-system-file-checker-in-windows-10-365e0031-36b1-6031-f804-8fd86e0ef4ca

If still having same problems, try reinstalling the game if you haven't already.
I followed those instructions exactly, reinstalled the game, but it didn't change anything.
I really can't understand what it's causing this.
 

ASK THE COMMUNITY

TRENDING THREADS