CD-ROM drive, now ya see it, now ya don't???


Dec 1, 2002
To make a long story short;
I've just formatted the hard drive, booted up with a WinME boot disk And I cannot get the OS installed. I get an error msg:
CDR101: Not ready reading drive E
Abort, retry, fail

The long version, everything I've tried so far:
Everything seem to be running just great for a couple of weeks. Then it started "getting buggy," error msg's, trouble getting game CD's to auto-start… I did try to "tweak" some improvements in the BIOS along the way; but that's all history now because… I finally decided to reformat the hard drive, and reinstall the OS. I've put three partitions on the 40GB hard drive. Where I originally was using WinME, based on feedback I gotten, I now have XP.

Last week when I put the boot floppy and WinME CD in, chose "boot with CD support" and eventually ended up at the "A" prompt… moved to the "G" prompt (my CD-ROM drive) and entered "setup.exe" and got the response:
CDR101: Not ready reading drive G
Abort, retry, fail
This was with the IDE cable in the number 1 connection on the mobo (K7S5A), the middle connection plugged into the CD-ROM, which is jumper set to be the slave device; and the end connection plugged into the hard drive, jumper set to be the master device. I double-checked it all. The BIOS is set to auto-detect the CD-ROM. I also put a different CD-ROM drive in, and got the same results.

Based on suggestions received, I have now moved the CD-ROM drive to the secondary IDE channel on the mobo, with it's own cable of course, and jumpered it to Master. The hard drive is still on the first IDE also jumpered as Master.
The BIOS is set to auto detect, confirmed in the POST on boot up, which shows the hard drive as the primary master and the CD-ROM as the secondary master.

I have gone into the BIOS and chosen "optimal settings," which, according to the mobo manual gives me the most reliable, although not the fastest, setup configuration.

So now I put the XP CD in, turn it on, and it goes through the usual POST, etc. Eventually getting to:
Searching for boot record from floppy…not found (because XP doesn't need one…right?)
Searching for boot record from CD-ROM…not found (XP is in the CD-ROM?? )
Searching for boot record from IDE-0…OK
At this point it just hangs…there is no boot record in IDE-0, which I believe is the hard drive - I'm not sure…the BIOS gives me the choice of IDE 0, 1, 2, or 3; and
I have two IDE channels on the mobo, so I'm guessing 0 and 1 are on IDE channel 1; and 2 and 3 are on channel 2…??

Just for the halibut - I left XP in the CD-ROM drive, put my WinME boot disk in the floppy… ended up at the "A" prompt… moved to the "G" prompt (my CD-ROM drive) and entered "setup.exe" and got the response:
CDR101: Not ready reading drive G
Abort, retry, fail
The CD-ROM opens and closes normally, and the light, on the front, goes on (for a little while) when the XP CD is inserted, or when it's searching for a boot record;
but then the light goes off without results. I've made a copy of the XP CD, and tried both on computers at work - there's no fault with the actual CD's.


Jun 27, 2002
If that was a short story, how is the long story :lol: . As far as I can tell your CD drive is defect. Have you tried that drive in another machine?

<i><b>Engineering is the fine art of making what you want from things you can get</b></i>
<A HREF="" target="_new">My systems</A>


Dec 31, 2007
Yep, my money would be bet on a dead/dying cdrom drive.

<b>Just because someone's a member of an ethnic minority doesn't mean they're not a nasty small-minded little jerk. <i>Terry Pratchett</i></b>

Similar threads