• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

CD-ROM won't start up certain games

G

Guest

Guest
I've only run across this problem a couple of times, but it's sort of irritating. With the games Sacrifice and now Black&White, when trying to start the game with the cd in my fast Creative 52X, it takes about 5 minutes of the splash screen while it's trying to load, and then it gives me an error stating that the cd may not be in the drive or the drive may be open. It's reading that drive like crazy, and I can hit cancel and it'll continue into the game just fine. I can, however, put the cd into my slower 8X CDR and it'll start up much faster and without the error, though the speed during the game won't be up to the 52X's standards. Any help from anyone would be greatly appreciated.
 

machow

Distinguished
Dec 31, 2007
855
0
18,980
0
Is that 52x brand new? Need some cleaning? Or a faulty product? Is it only these 2 CDs or ALL CDs you've tried?

------------------
This site is cool.
 

ejsmith2

Distinguished
Feb 9, 2001
3,228
0
20,780
0
You might try a bios update. Some games use a copy protection which doesn't like anything but a cd-writer. That's what is so awesome about copy protected games: you can't play them, no one else can play them, so no one wants them, and no one pirates them. But, the company still got it's money. Darn good marketing strategy.
 
G

Guest

Guest
Yeah...sorry I didn't make that clear. It's only on these two cd's that its giving me problems. Every other cd runs perfectly. Just Sacrifice and Black&White. So I'm sure its also not a dirty/faulty drive. Is there anything software wise that I could try to remedy this problem?
 

Dai

Distinguished
Dec 31, 2007
24
0
18,510
0
I have exactly the same problem, even the same CD ROM drive (Creative 52X). As a matter of interest, I am running Windows 2000 and I wasn't sure whether it is OS dependant. Which OS are you running?

The problem also occurred with Heroes of Might & Magic III (The last one). It's an extremely irritating problem though after the five minutes loading, it seems to run fine!

It would be great to find a fix for this!

Dai
 
G

Guest

Guest
I'm also running Windows 2000. Hmmm...it could be OS related, I guess. I tried to find updated drivers from it at Creative.com but couldn't find any for Win2k. Perhaps its just not fully supported? A workaround would be greatly appreciated if somebody could provide one. Thanks again in advance.
 

ejsmith2

Distinguished
Feb 9, 2001
3,228
0
20,780
0
Some cdroms just don't work with certain copy protections. Diablo 2 has the same problem. Check out the Black and White web site, and even the Diablo 2 web site to see which drives have problems. It's on the FAQ.

You can crack the game so you can play it, although I hope you have the 'original' =)

Check out <A HREF="http://www.gamecopyworld.com" target="_new"> GameCopyWorld</A>
 

ASK THE COMMUNITY

TRENDING THREADS