Question Certain games having weird freezes

Knucklez

Honorable
Dec 4, 2014
28
1
10,540
1
Hi,

I have stumbled upon a very weird problem I am having with a few games.

I witnessed this last week when playing through the Hitman trilogy (happened in all three), and this week in Yakuza Kiwami 2, though it's a bit different in both.

In Hitman, I would get a freeze every 30secs-minute, which would last a second or two. The audio would carry on as normal, just the screen would freeze. The game was running at over 60fps no problem.

In Yakuza, I am getting these more often, but they are literally a split second, and would happen even in the menus. Say I am selecting a tab, the game might freeze for a second and then jump 2-3 tabs, or if I'm walking and moving the camera, the camera might freeze and then do a crazy 180 degrees. This can get really annoying especially in fights. Again, audio works fine.

I have tested some other games such as NFS Heat, Forza Horizon 4, and Cyberpunk which I think is way more demanding than Hitman or Yakuza, and this issue does not exist.

Any idea what could be causing this?

My specs are:
Intel Core i9 9900K overclocked to 4.8GHz
RTX 3080
Aorus Pro Z390
16GB RAM DDR4
PSU: Kolink Continuum 1050W 80 Plus Platinum
 

Colif

Win 10 Master
Moderator

Knucklez

Honorable
Dec 4, 2014
28
1
10,540
1
Try a clean boot and see if it changes anything - make sure to read instructions and make sure NOT to disable any microsoft services or windows won't load right - https://support.microsoft.com/en-au/help/929135/how-to-perform-a-clean-boot-in-windows

if clean boot fixes it, it shows its likely a startup program. You should, over a number of startups. restart the programs you stopped to isolate the one that is to blame.
Thanks for the advice. Unfortunately, this didn't fix it. What's even more weird is that when I first installed the game 2 days ago, it was working fine. When I ran it the next day, that's when the issues began.
 
Thanks for the advice. Unfortunately, this didn't fix it. What's even more weird is that when I first installed the game 2 days ago, it was working fine. When I ran it the next day, that's when the issues began.
to my mind it looks like you have an issue with your GPU

can you source another gpu from somewhere to verify?

Also can you set your bios to "optimized defaults"
 

Knucklez

Honorable
Dec 4, 2014
28
1
10,540
1
to my mind it looks like you have an issue with your GPU

can you source another gpu from somewhere to verify?

Also can you set your bios to "optimized defaults"
Would be quite difficult for me to get another GPU to be honest. I could speak to overclockers support who have custom built the PC for me, and see if they can help out.

What makes you think it's the GPU? Wouldn't that affect all games?

Also with the bios 'optimised defaults', would that affect the overclocking of CPU?
 
Would be quite difficult for me to get another GPU to be honest. I could speak to overclockers support who have custom built the PC for me, and see if they can help out.

What makes you think it's the GPU? Wouldn't that affect all games?

Also with the bios 'optimised defaults', would that affect the overclocking of CPU?
it's because of your freezes, not sure though, thats why it would be best to test it

As you said it doesn't happen with more demanding games, but i'd still check it out as it can save us MUCH troubleshooting hassle (regardless of result it will tell us something)

yes it would affect your oc, it would basically reset your bios to out of the box settings
 

Knucklez

Honorable
Dec 4, 2014
28
1
10,540
1
it's because of your freezes, not sure though, thats why it would be best to test it

As you said it doesn't happen with more demanding games, but i'd still check it out as it can save us MUCH troubleshooting hassle (regardless of result it will tell us something)

yes it would affect your oc, it would basically reset your bios to out of the box settings
I'm sending the RTX back for looking into. Let's see what comes out of that, I can get a replacement if it really is the GPU. I also done a quick video in Yakuza to show what's happening:
https://streamable.com/a057jb

Can really see the lag at around 0:13, 0:20 and 0:27.
 

Knucklez

Honorable
Dec 4, 2014
28
1
10,540
1
Hi,

So I got a new RTX as a replacement, and unfortunately this is still happening (tested in Yakuza Kiwami 2). Could installing the game onto the SSD instead of the HDD help? I'm running out of ideas as to what could be causing this.
 
Hi,

So I got a new RTX as a replacement, and unfortunately this is still happening (tested in Yakuza Kiwami 2). Could installing the game onto the SSD instead of the HDD help? I'm running out of ideas as to what could be causing this.
Yes, that would be the next step

now that we have ruled out the gpu, your hdd/ssd (wherever win is installed) is suspect
 

Knucklez

Honorable
Dec 4, 2014
28
1
10,540
1
Yes, that would be the next step

now that we have ruled out the gpu, your hdd/ssd (wherever win is installed) is suspect
Thanks for all your help. I've reinstalled to SSD but still the same problem. I've managed to fix it though...

No idea how this affects the game (maybe auto-save), but switching off Wi-Fi has removed the stuttering. I can't test this on hitman as I don't have the game anymore, but I'll keep an eye on this within Yakuza and if it happens in another game again.
 
Reactions: Quanticriver

ASK THE COMMUNITY

Latest posts