Question Change 5950x frequency vs. workload defaults OR....

Apr 30, 2022
8
0
10
0
Hi everyone.

I have a 5950x running stock (no OC). Peak speed per Ryzen Master capped at roughly 2ghz during my main workload (audio editing in Adobe Audition with various audio effects).

Problem is that's not fast enough. I keep dropping samples due to the effects processing. Troubleshooting this with 1 effect confirms that the effect is running on a separate core (also validated with the manufacturer (Fabfilter Pro Q3). I need that effect processed at a faster rate to allow for real-time editing. At 2ghz it can't process the effect faster than 11ms—that's too slow.

I"m trying to either 1) lock the clock at a higher frequency or 2) change how the 5950x responds to workload to make it clock higher).

I've tried 1) disabling Global c-states, 2) disabling Fabric clock c states, tried Ryzen Master auto overclocking, setting the Clock multiplier by hand in the bios, and Clock tuner for Ryzen. Tried High Performance power plan in windows. 5950x seems to do whatever it wants no matter what I try.

Any ideas??????? Really need some help here.....

Thanks!
Mike
 
Hi everyone.

I have a 5950x running stock (no OC). Peak speed per Ryzen Master capped at roughly 2ghz during my main workload (audio editing in Adobe Audition with various audio effects).

Problem is that's not fast enough. I keep dropping samples due to the effects processing. Troubleshooting this with 1 effect confirms that the effect is running on a separate core (also validated with the manufacturer (Fabfilter Pro Q3). I need that effect processed at a faster rate to allow for real-time editing. At 2ghz it can't process the effect faster than 11ms—that's too slow.

I"m trying to either 1) lock the clock at a higher frequency or 2) change how the 5950x responds to workload to make it clock higher).

I've tried 1) disabling Global c-states, 2) disabling Fabric clock c states, tried Ryzen Master auto overclocking, setting the Clock multiplier by hand in the bios, and Clock tuner for Ryzen. Tried High Performance power plan in windows. 5950x seems to do whatever it wants no matter what I try.

Any ideas??????? Really need some help here.....

Thanks!
Mike
Ryzen Master shows "Effective frequency" (as if it was a single core ) in simple mode, need to look in Advanced mode to see each core frequency. In single core/thread applications only 1 or 2 cores will boost.
To make all cores work at same frequency you need to set manual multiplier with appropriate voltage.
In Power management, set Minimum CPU state to 100%.
Also run a benchmark program like Cinebench r23 while monitoring frequency, voltage and temps, specially temps as anything over 90c will severely limit boost.
 
The 5950x is a hot running processor however at stock it has plenty of Overhead and 5GHz is easy to achieve if you have the correct cooler.
It is best to disable boost in Bios and go all core OC.
There are some Overclocking guides on Youtube that help with advanced OC however all systems are different so review some and if confused, come back and just ask about it. Advanced overclock options usually require adjustments to Core Voltage, Frequency gains using your multiplier, LLC (Load Line calibration) to ensure stability.
Don't use Ryzen Master to interact with Bios, just use it for monitoring. It's best to learn your Bios to make stable overclocks.

This vid maybe of help if your MB is ASUS Dark Hero:
View: https://www.youtube.com/watch?v=NTkRuZ3uSO4


If not your particular Bios the principles are the same and there is lots of info at Overclock.net.
 
Apr 30, 2022
8
0
10
0
Got it. Thanks CountMike. Verified the CCX as indeed clocked to my manual multiplier. in Ryzen Master. Also verified at full load well under 90c.

I still see the 5950x cores sleeping. On Intel I could prevent cores from sleeping/slowing down. Any idea how to do that on a 5950x?
 
Last edited:
Apr 30, 2022
8
0
10
0
Ok...looks like it got this working. Here's how I did it.

The all-core boost does not stick; AMD's power management algorithms in the 5950x prevent it from staying at the overclock clock speeds (it throttles down). I therefore needed to (on a Asus Tuf Gaming x570 PRO wifi motherboard):

  1. Disable "Precision Boost Overdrive" in the "ASUS OverClocking section" (Advanced Menu)
  2. Disable "Precision Boost Overdrive" AND "PBO Fmax Enhancer" in the "Ai Tweaker" section"
  3. Set "OC Tuner" to "Keep Current Settings"
  4. Set "Performance Bias" = None
Also disabled "Global C-states" (Advanced\AMD CBS) AND "DF C-states" (Advanced/AMD CBS/NBIO Common Options/SMU Common Options. But I don't think these were necessary to lock the clock (I'm just looking for lowest latency as possible).

I also noted that installing and running Ryzen Master messes things up. Before Ryzen Master install, HWInfo64 reports Effective clock speed to be my overclock frequency. After Ryzen master install it reports Effective clock speed to be variable. Uninstalling Ryzen master doesn't fix the issue. After Ryzen master uninstall I had to go back into the bios, reset everything to Default (press F5), then make all the changes I noted above all over again....and only then was the effective clock locked to my overclock frequency.

Hope that helps anyone else looking to lock a Ryzen CPU at a specific frequency.
 
Apr 30, 2022
8
0
10
0
Nope...spoke too soon. HWInfo64 reports a locked clock speed when it first opens. If you close it and open it again, then it shows a variable clock.

So....starting to get frustrated here.....time for a rant.....been working on this for like 3 days straight:

------Rant Start-------

With Intel CPUs just disable SpeedStep, EIST and Speedshift. Easy.

But AMD forces variable clocks on customers??? With no way to override it??? This means that I'm forced to use what AMD feels is a "good enough" clock speed . Well, 2.3 GHZ on 2 cores is not fast enough in my case; I'm getting samples dropped. If I could lock the CPU to 4 ghz or even 3.4 ghz: problem solved.

WTF AMD???????????????????????????????????????????

-----Rant End----------

Can anyone out there help/give me any ideas? I spent $900 on this CPU/DDR4/Motherboard combo and it's not meeting my use-case.
 

wyliec2

Distinguished
Apr 4, 2014
147
12
18,715
11
If I could lock the CPU to 4 ghz or even 3.4 ghz: problem solved.

WTF AMD???????????????????????????????????????????

-----Rant End----------

Can anyone out there help/give me any ideas? I spent $900 on this CPU/DDR4/Motherboard combo and it's not meeting my use-case.
It's important to list your full system specifications in order for others to assist you.

Assuming you have good cooling (ie. 280 or larger AIO) you should be able to achieve an all-core OC of 4.0 Ghz fairly easily. I do video encodes which may run the CPU at 90%+ for days (literally) with a 4.5 Ghz OC.

Because of my workload, PBO doesn't give maximum performance but it has never been as bad as you describe. IIRC the base frequency - all PBO, etc. off and BIOS defaults should be 3.5 or 3.6 Ghz.

You don't mention the temps you're seeing - high-temperature throttling could cause the issues you describe.

As suggested, searching out 5950x overclocking info should get you in the right direction. Again, with good components, 4.0 Ghz should be easy without any esoteric BIOS manipulation - you mention CCX - I've never touched that.
 
Nope...spoke too soon. HWInfo64 reports a locked clock speed when it first opens. If you close it and open it again, then it shows a variable clock.

So....starting to get frustrated here.....time for a rant.....been working on this for like 3 days straight:

------Rant Start-------

With Intel CPUs just disable SpeedStep, EIST and Speedshift. Easy.

But AMD forces variable clocks on customers??? With no way to override it??? This means that I'm forced to use what AMD feels is a "good enough" clock speed . Well, 2.3 GHZ on 2 cores is not fast enough in my case; I'm getting samples dropped. If I could lock the CPU to 4 ghz or even 3.4 ghz: problem solved.

WTF AMD???????????????????????????????????????????

-----Rant End----------

Can anyone out there help/give me any ideas? I spent $900 on this CPU/DDR4/Motherboard combo and it's not meeting my use-case.
Take a look at this
https://hothardware.com/reviews/amd-power-curve-optimizer-guide-zen-3
 
Nope...spoke too soon. HWInfo64 reports a locked clock speed when it first opens. If you close it and open it again, then it shows a variable clock.

So....starting to get frustrated here.....time for a rant.....been working on this for like 3 days straight:

------Rant Start-------

With Intel CPUs just disable SpeedStep, EIST and Speedshift. Easy.

But AMD forces variable clocks on customers??? With no way to override it??? This means that I'm forced to use what AMD feels is a "good enough" clock speed . Well, 2.3 GHZ on 2 cores is not fast enough in my case; I'm getting samples dropped. If I could lock the CPU to 4 ghz or even 3.4 ghz: problem solved.

WTF AMD???????????????????????????????????????????

-----Rant End----------

Can anyone out there help/give me any ideas? I spent $900 on this CPU/DDR4/Motherboard combo and it's not meeting my use-case.
Intel also throttles when heat or anything else goes above the limits, it might even revert OC settings if they are unsafe (the mobo will) ,have you checked that this isn't the case?
You should actually enable precision boost since that boosts the single thread of one or two threads while keeping the others low, also enabling precision boost override will give the CPU more headroom to boost those two cores higher.
 
Apr 30, 2022
8
0
10
0
Thanks CountMike. Interesting idea to modify the performance curves using curve Optimizer. I'll try that tonight. I wonder if that will give me the kind of clock speed I'm looking for under low load. My understanding is that curve optimizer modifies voltage down per frequency to allow the cores to clock slightly higher; improvement seem to be in the 5%-8% range (in my case increasing clock speed at low load to 2.2ghz instead of 2ghz); not sure that will be enough.

From what I can see of the 5000 series design, adjusting Pstates may be the way to go. I don't need a crazy high P0 speed (max load overclock) because in my case, the CPU doesn't even get past 3% load. I thinking raising the low load pstate frequencies/voltages slightly (I'm thinking 3ghz?) will increase my low load speeds and fix the problem. Lower pstates set to 3ghz, should give me a 30% speed increase at the load I'm typically under in my particular use case. Don't think heat will be a problem: at 1.2 vcore, 4ghz an allcore Cinebench R3 bemchmark give max temp at 75c.
 
Apr 30, 2022
8
0
10
0
Intel also throttles when heat or anything else goes above the limits, it might even revert OC settings if they are unsafe (the mobo will) ,have you checked that this isn't the case?
You should actually enable precision boost since that boosts the single thread of one or two threads while keeping the others low, also enabling precision boost override will give the CPU more headroom to boost those two cores higher.
I'm very far away from those limits in my particular use case. I'm at 2-3% load, temp at max 40c. CPU is at about 20watt per Ryzen master; way under limits.

PBO, unfortunately, did not help. Neither did: auto overclock, adjusting the frequency multiplier, or clock tuner for ryzen. These overclock methods boost clockspeed at full load. I need the clock boosted a low-loads, rather then the typical overclock paradigm which is to increase the max "single core" or "all-core" clock. I think what I need to do is adjust the default lower pstates (p9-p3?) frequencies higher.
 
Apr 30, 2022
8
0
10
0
It's important to list your full system specifications in order for others to assist you.

Assuming you have good cooling (ie. 280 or larger AIO) you should be able to achieve an all-core OC of 4.0 Ghz fairly easily. I do video encodes which may run the CPU at 90%+ for days (literally) with a 4.5 Ghz OC.

Because of my workload, PBO doesn't give maximum performance but it has never been as bad as you describe. IIRC the base frequency - all PBO, etc. off and BIOS defaults should be 3.5 or 3.6 Ghz.

You don't mention the temps you're seeing - high-temperature throttling could cause the issues you describe.

As suggested, searching out 5950x overclocking info should get you in the right direction. Again, with good components, 4.0 Ghz should be easy without any esoteric BIOS manipulation - you mention CCX - I've never touched that.
Thanks wyliec2.

Relevant (i think) specs are:

  1. Motherboard: Ass Tuf Gaming Pro wifi (latest BIOS)
  2. CPU: 5950x
  3. RAM: 32 GB 14-15-15-35 Teamgroup ram (16gbx2)
  4. Temps: Noctura 120mm cpu cooler: At 1.2 vcore, 4ghz, max core temp is ~75c (can get to 4ghz at a low vcore, but wanted to stress test the cooler).
  5. Nvidida 1050 TI
  6. OS: windows 10 21H2
This is my use case, in breif:

  1. Running Adobe audition with Fabfilter Q3, multiple instances all set to Linear Phase
  2. The ASIO buffer is set to 256 samples, which at 44.1hz sample rate gives me 11ms of buffer time. I can't increase the buffer time past 11ms because the visual frequency spectrum of the eq will not match the audio playing (long story). When they don't match, it very, very hard to use the EQ.
  3. This means that the CPU must process the multiple instances of fabfailter eq settings, and realign the phase changes from each eq setting within 11ms. If it can't do that, audition "moves on" skipping the audio that the CPU could not process in time. The result playback gaps and/or pops and clicks.
  4. From a load perspective, this is a joke for any modern CPU: there really is not much to do and CPU load never goes above 2%-3%.
  5. Due to the variable-clock algorithms in in the 5950x, seeing a low load = lower clock speed, so the clock never goes past 2ghz in the active cores in my use case.
  6. At 2ghz, the CPU can't complete the task in time and audition skips the audio the CPU could not process in time.
  7. The 5950x variable-clock algorithim seems unaware that it has 11ms to complete the task assigned to it and thereby fails to boost it's variable-clock to even the 5950x baseline of 3.4 ghz.
The only thing I can think of that may address this is increasing the frequency of the lower-power pstates (P9-P3?) . I'm thinking of setting all the Pstates to run at 3.4 ghz. That should allow the 5950x to enter cstates (most cores are not used in my use case) and thereby stay cool, but when ANY work is presented, the clock will be locked at 3.4 ghz and not be variable.

Thoughts?
 

wyliec2

Distinguished
Apr 4, 2014
147
12
18,715
11
Thanks wyliec2.

Relevant (i think) specs are:

  1. Motherboard: Ass Tuf Gaming Pro wifi (latest BIOS)
  2. CPU: 5950x
  3. RAM: 32 GB 14-15-15-35 Teamgroup ram (16gbx2)
  4. Temps: Noctura 120mm cpu cooler: At 1.2 vcore, 4ghz, max core temp is ~75c (can get to 4ghz at a low vcore, but wanted to stress test the cooler).
  5. Nvidida 1050 TI
  6. OS: windows 10 21H2
This is my use case, in breif:

  1. Running Adobe audition with Fabfilter Q3, multiple instances all set to Linear Phase
  2. The ASIO buffer is set to 256 samples, which at 44.1hz sample rate gives me 11ms of buffer time. I can't increase the buffer time past 11ms because the visual frequency spectrum of the eq will not match the audio playing (long story). When they don't match, it very, very hard to use the EQ.
  3. This means that the CPU must process the multiple instances of fabfailter eq settings, and realign the phase changes from each eq setting within 11ms. If it can't do that, audition "moves on" skipping the audio that the CPU could not process in time. The result playback gaps and/or pops and clicks.
  4. From a load perspective, this is a joke for any modern CPU: there really is not much to do and CPU load never goes above 2%-3%.
  5. Due to the variable-clock algorithms in in the 5950x, seeing a low load = lower clock speed, so the clock never goes past 2ghz in the active cores in my use case.
  6. At 2ghz, the CPU can't complete the task in time and audition skips the audio the CPU could not process in time.
  7. The 5950x variable-clock algorithim seems unaware that it has 11ms to complete the task assigned to it and thereby fails to boost it's variable-clock to even the 5950x baseline of 3.4 ghz.
The only thing I can think of that may address this is increasing the frequency of the lower-power pstates (P9-P3?) . I'm thinking of setting all the Pstates to run at 3.4 ghz. That should allow the 5950x to enter cstates (most cores are not used in my use case) and thereby stay cool, but when ANY work is presented, the clock will be locked at 3.4 ghz and not be variable.

Thoughts?
I'm not familiar with your software or it processing requirements. If I understand correctly you're saying it's not an extensive load for concurrent threads but is very sensitive to latency with a few threads. I would think 11ms would not be a challenge for processors that schedule/work in microseconds....

In any case, is it correct that if all cores were running at 3.4 Ghz or higher, your problem would be resolved?

You mention a Noctua(?) 120mm CPU cooler - air? A high-end Noctua (or other) air cooler would generally be considered the minimum for a 5950x with AIO liquid coolers being more common.

You didn't mention the speed of your RAM (ie. 3200, 3600) - you listed timings/latency; do you have DOCP enabled? Also, the exact model of Noctua cooler as well as the exact power supply brand, model, etc. are important.

I have an ASUS Crosshair Formula VIII mobo - I'll take a look tomorrow at the settings I have - I've only changed 10-12 items in developing my all-core OC.
 
Apr 30, 2022
8
0
10
0
OK...Looks like this time I really found the issue. Turns out Windows 10 was ignoring the power plan settings. I had to do THIS which enabled a setting in the advanced power management options "Disable Idle". Enabling "disable idle" stopped the core from variable clocks.

Thanks everyone for your input! If anyone wants to lock their AMD Ryzen clock speed on windows 10 21H2 I suggest followign the link provided!

Best,
Mike
 
OK...Looks like this time I really found the issue. Turns out Windows 10 was ignoring the power plan settings. I had to do THIS which enabled a setting in the advanced power management options "Disable Idle". Enabling "disable idle" stopped the core from variable clocks.

Thanks everyone for your input! If anyone wants to lock their AMD Ryzen clock speed on windows 10 21H2 I suggest followign the link provided!

Best,
Mike
Great find. Are you getting better results now ?
 

ASK THE COMMUNITY