Change Password without Ctrl+alt+del and RDP within RDP

Status
Not open for further replies.

viper312s

Honorable
Mar 19, 2013
2
0
10,510
0
I can't change password in a domain when I am RDP via RDP and Ctrl+Alt+End only works on the first connection.

Unfortunately I can only get to my DMZ domain via a production server. Ideas?

Thanks!

Steve
 

neduddgi

Honorable
Oct 8, 2013
1
0
10,520
1
Use the On-Screen Keyboard (osk.exe). You can press Ctrl-Alt-Del virtually!
Holding ctrl-alt on the top-level machine and clicking the 'del' in the desired level OSK works.
 

Pinhedd

Champion
Moderator
Hi Steve,

If password changes are allowed on the authenticated account you can change the password through Control Panel -> User Accounts -> Change your windows password.

Ctrl-Alt-Del is trapped by the machine to which the keyboard is connected, so it will never be passed to any application and thus never to a remote machine. This is a security feature. To pass a Ctrl-Alt-Del you must click on the button that is present on most terminal windows (not sure where it is on RDP).
 
CTRL-ALT-END is the key combo to send a CTRL-ALT-DEL to the remote RDP desktop. What version of Windows is the RDP desktop you are controlling? (Windows Vista +, and Windows Server 2008 + should allows for the password change by sending the keystrokes.
 

viper312s

Honorable
Mar 19, 2013
2
0
10,510
0
Pinhead

Thanks for your reply but the first suggestion (Control Panel) was the first thing I tried after I noticed ctrl+alt+end didn't work. Once I get to my account I have the options to "Change user Account Control Settings" and "Manage user Accounts" and then it says "To change your password, press Ctrl+Alt+Del and select Change a password." :fou:

I don't have a button unfortunately on Window's RDP and/or mRemoteNG...lame :(



 

neduddgi

Honorable
Oct 8, 2013
1
0
10,520
1
Use the On-Screen Keyboard (osk.exe). You can press Ctrl-Alt-Del virtually!
Holding ctrl-alt on the top-level machine and clicking the 'del' in the desired level OSK works.
 

mbelsky

Honorable
Oct 22, 2013
1
0
10,510
0


Genius!
 

markallard

Honorable
Nov 6, 2013
1
0
10,510
0


Yep, Genius!! Not just an outside the square thinker; what square?! I've been puzzling over this for months, probably years
 

pkaayaa

Honorable
Nov 6, 2013
1
0
10,510
0
This is a solution when one is remote through a remote machine.

Bring the on screen keyboard [Start -> Programs -> Accssibility -> On-Screen Keboard]

While the On Screen Keyboard is in focus, On your key board, press CTRL + ALT and click on the DEL button the on On-Screen Keyboard.
 

NenaHagen2010

Reputable
Apr 9, 2014
4
0
4,510
0
on a stand alone computer: START > RUN > CMD > Net Use "user name" "password"

without the quotes.

on a domain connected computer : START > RUN > CMD > Net Use "user name" "password" /domain

without the quotes.
 

jflarvoire

Reputable
Apr 25, 2014
1
0
4,510
0
Hi,
I'm stuck with this same problem, and none of these suggestions work for me...
* Pressing Ctrl-Alt-Del on the OSK brings up a popup saying
"To use the commands available when you press Ctrl+Alt+Del, click on your user tile and choose an option."
And when I click on my user tile, the only options are "Lock" and "Sign Out".
* The net user command fails with the message:
"Access is denied".
 

Tr0jan

Reputable
Jun 5, 2014
1
0
4,510
0
You can enable sticky keys (shift 5 times quickly) that will allow you to press ctrl then alt then delete individually.

The only thing to bear in mind is that you will get the sticky keys prompt in every RDP and sub-RDP window, so be sure to cancel all other than the machine you want to change password on.

 
Status
Not open for further replies.

ASK THE COMMUNITY

TRENDING THREADS