Change to AHCI problem

kro10000

Honorable
Oct 16, 2012
11
0
10,510
0
Ok, I know that this has been brought up in one form or another a million times, but my situation is just different enough to validate a new post.

The system involved is the one in my signature, the motherboard has 5 SATA ports and with this latest SSD install, I now have 6 SATA devices. So I bought a cheap inland 2 port PCIe SATA controller to run one or both of my optical drives (if yet another HDD finds its way into my case). For what it's worth the SATA controller says it is compatible with AHCI "Spec. Rev. 1.3". For the SSD install I did not do a clean install of windows, I cleared out enough space on the boot drive and used Acronis Trueimage to clone onto the SSD.

Anyway in my BIOS settings the current storage configuration is IDE, so I followed all the tutorials and found the Msahci "start" registry key, but its value was already 0? I also changed the IastorV "start" key and changed its value from 3 to 0. Then going back to the BIOS I changed the storage configuration to AHCI from IDE and when I tyr to boot the computer locks at the animated windows logo. If I go back to IDE it boots fine.

I'm hoping for some advice on this issue, I don't know if the SATA controller could be causing the problem, or something else I have overlooked.

Thanks in advance
 

inzone

Champion
Moderator
You are trying to boot off the SSD that has a cloned Windows image? What did you do with your original Windows install? In the sata ports make sure that the SSD is connected to port 0 (since it starts 0,1,2 etc) so that it's on the first sata port.
I would also try to start the computer with the SSD disconncted if you still have the original OS install on the other drive.
 

kro10000

Honorable
Oct 16, 2012
11
0
10,510
0
Didn't realize that my signature didn't appear, here are the specs of my system:
Case: NZXT Tempest 410
CPU: AMD Phenom II X4 970 OCd to 4.0 Ghz
Motherboard: ASRock 870 Extreme 3
Graphics: Sapphire Radeon HD6870
8 GB RAM
HDDs:
OCZ Vertex 4 120GB
1TB Hitachi Green
500GB Seagate 2.5 Hybrid
320GB Western Digital Blue
Optical:
LG Blueray ROM
LG DVD-RW
Cooling:
Cooler Master Hyper 212+
6 Misc 120mm fans
Other:
Cheap PCI WIFI card
Inland PCIe SATA expansion card
 

Similar threads


ASK THE COMMUNITY