Question Changed my ram and pc won't show display

Soarim

Honorable
Nov 13, 2015
49
0
10,530
0
I bought 2x 8gb 3600mhz to upgrade my system, I have a ryzen 7 3700x, rtx 2070 super, b450m steel legend, and I was using 2x 8gb 2400mhz, which was really holding back my cpu and causing stuttering in games, so I changed the ram with the new modules and it won't show display, the computer work, gpu fans ramp up, cpu fan working as well, everything seem to be working, but it won't show display, so, I try to put back my old ram modules, same thing, no display, I'm really worried, if anyone can help me..
 

CDDogg

Honorable
Aug 20, 2015
248
3
10,715
14
I had some similar issues with a B550 Steel legend myself earlier today.

Check your USB devices, if your usb devices don't power on at all, then the PC isn't POSTing. It's probably some issues with the ram voltage and timings. Clear CMOS, seat the sticks in the A2 and B2 slots. Then try booting.

If you can get into the BIOS then you're already halfway there, play around with the timing and voltage settings until you can get a stable boot into windows. If windows crashes or errors while booting don't worry, it just means you need to tweak the ram settings some more.
 

Soarim

Honorable
Nov 13, 2015
49
0
10,530
0
I had some similar issues with a B550 Steel legend myself earlier today.

Check your USB devices, if your usb devices don't power on at all, then the PC isn't POSTing. It's probably some issues with the ram voltage and timings. Clear CMOS, seat the sticks in the A2 and B2 slots. Then try booting.

If you can get into the BIOS then you're already halfway there, play around with the timing and voltage settings until you can get a stable boot into windows. If windows crashes or errors while booting don't worry, it just means you need to tweak the ram settings some more.
Thanks for the reply, man, I think it will be helpful, but my usb devices are working, mouse, keyboard, and headset all worked when hit the power button, Idk if that's what's you mean by saying usb devices, but when I get home I will do as you said
 

Soarim

Honorable
Nov 13, 2015
49
0
10,530
0
I had some similar issues with a B550 Steel legend myself earlier today.

Check your USB devices, if your usb devices don't power on at all, then the PC isn't POSTing. It's probably some issues with the ram voltage and timings. Clear CMOS, seat the sticks in the A2 and B2 slots. Then try booting.

If you can get into the BIOS then you're already halfway there, play around with the timing and voltage settings until you can get a stable boot into windows. If windows crashes or errors while booting don't worry, it just means you need to tweak the ram settings some more.
I've tried everything and it's just not booting, not with the new ram and not with the old ram...
 

Soarim

Honorable
Nov 13, 2015
49
0
10,530
0
I had some similar issues with a B550 Steel legend myself earlier today.

Check your USB devices, if your usb devices don't power on at all, then the PC isn't POSTing. It's probably some issues with the ram voltage and timings. Clear CMOS, seat the sticks in the A2 and B2 slots. Then try booting.

If you can get into the BIOS then you're already halfway there, play around with the timing and voltage settings until you can get a stable boot into windows. If windows crashes or errors while booting don't worry, it just means you need to tweak the ram settings some more.
hey, i managed to make it work using my old ram modules, not really interested in trying the new ones again, im gonna go to someone who can say if the ram is faulty
 

ASK THE COMMUNITY

TRENDING THREADS