Question Changed RAM now no display

Jan 12, 2021
2
0
10
0
Hey guys,

I'm new here and not the best with computers so I'll do my best to explain:

I just installed new ram into my pc, going from 2x8gig ddrm4 2800 to 2x16gig ddrm4 3200 which my motherboard should be able to handle according to the website. I installed the ram like you are supposed to, however when I went to plug everything back into my pc I got no display from the graphics card. I tried different ports, going back to the old ram, but nothing has helped. I got one display working for a few minutes by plugging hdmi into the motherboard, but the signal was lost again after a few minutes.

Before I lost display again, I checked and my system showed the ram to be in place and working if that helps at all.

Any help at diagnosing what went wrong would be greatly appreciated.

As I typed that, the display from the mobo hdmi came back up on its own, so I really have no clue what is happening with my machine.

Edit: after reading other posts some additional information-
I have booted into windows fine and am able to use my pc as normal with the one working display, when it works (it keeps going in and out)
 
Last edited:
Jan 12, 2021
2
0
10
0
Hello everyone,

So tonight I decided to upgrade my ram, and after doing so I ran into a "no display" problem. Given i had just changed ram i figured that was what caused the issue. However after a bunch of trouble shooting I managed to plug a display into the mobo slot and booted into windows just fine...except upon further inspection my PC no longer saw my gtx 1080.

I dont know how it could have moved around since it is screwed in and I did not go near it but I'm thinking it might just have become slightly unseated. Should I take it out fully and put it back into the slot? I don't want to cause any more problems than I already have so am hesitant to act simply on my own
 

ASK THE COMMUNITY

TRENDING THREADS