Question changing CPU and lost half the ram

Aug 27, 2021
6
0
10
0
Hi,

I came on tom's hardware because I found a lot of information here while digging into my issue
I know it will seem similar to other, but I didn't find or understand the solution for my problem.

I had this configuration
Asus Z170 Pro Gamin
Intel I5-6600k
4 x 4 GB Vengeance LPX 2666 Mhz (all identical)

I recently bought a I7-7700k to upgrade my configuration.

But then I can see All my four DIMMS in the Bios, but only half of it in the total:
https://zupimages.net/up/21/34/s271.png


My bios is up to date.
XMP profile is off.
I tried to clear the CMOS.
I tried sticks 2 by 2 it works fine on both dimms slots.
When I put back my I5-6600k I do have 16 Gb in total.
Of course in Windows 10 Pro I see only 8 Gb of Ram.

User Benchmark only sees 2 sticks:
https://zupimages.net/up/21/34/pe3p.png


When the CM detected a new CPU or if it boots on safe mode, I can see the tatal RAM correctly:
https://zupimages.net/up/21/34/rsqn.png

So it feels to me that my dimms and my socket are fine.
But I don't know if i didn't configure m y bios correctly or if my cpu is faulty.

I have looked around the internet and found many similar issues. But I never found a solution that worked for me.

Thank you in advance for you help.

Regards,
Charly
 
Aug 27, 2021
6
0
10
0
Were the 4 sticks of ram part of 2 different sets?

Yes I bought 2 sets of 2 sticks separately with a year or two gap. But they are the exact same model and I've been running the four stick for four years now.
The problem just appeared when I changed the CPU.
If I put back my old CPU, it works fine with the four sticks.
 

Wynteriscoming

Prominent
Jan 25, 2020
21
2
515
0
Someone with more experience will have to verify this but that could be the problem. Does your PC show all 4 when XMP is off and 2 when it is on?
 
If the 6600K works, and the 7700K does not, it suggests to me that the 7700K may be defective.
It is most unusual to have a defective intel processor, but I encountered this once.

Be very careful when swapping processors.
It is easy to damage a socket pin if the cpu is not dropped in cleanly.
Such damage often results in ram issues.
 
Aug 27, 2021
6
0
10
0
Thanks for your help.
I was really cautious when I swap the CPU, and no pin appears to be bent on the socket.

Is there a way to check if it is the CPU or not ?
Would this explain why I can see the sticks in the "DIMM STATUS" in the bios, but not in "Memory". Is the second one controled by the IMC of the CPU ?
I don't want to file a reclamation on Ebay if it is my hardware that is not compatible.
 

ASK THE COMMUNITY