Question Check signal cable and maybe a broken gpu?

Nov 26, 2019
3
0
10
0
To start off all of my components are new. This is a very new build like just built it yesterday new. I’m not an expert on computers but I have tried everything I can think of and my monitor still seems to say “check signal cable” it’s not the cable from the monitor to pc I’m sure, the hdmi cable is pushed in all the way. I plugged the cable into the motherboard to see if anything would should up instead but nothing showed up there either which leads me to believe it’s a problem with the motherboard and not the gpu.

However that’s a problem on it’s own. Yesterday my gpu got stuck in its slot and I had to pull it out which broke the little clamp that holds it down off which I’m sure isn’t that important? ( hopefully) but I am worried I may have broken it when I pulled it off too hard.

I’ve taken out and cleaned the ram and tried to turn on the pc from the motherboard but still nothing. I’m not sure what to do and I’m truly worried I have to scrap the whole pc at this point.
 
Nov 26, 2019
3
0
10
0
full system spec? include make and model of the psu and monitor

what connection are you using? vga/dp/dvi/hdmi?
Motherboard- prime b450m-A
CPU- AMD Ryzen 3 2200g
RAM- Patriot viper elite series
GPU- Radeon RX 570
PSU- EVGA 500 B1 80+ bronze 500w
Monitor- Samsung curved monitor c27f591fd
I have a SSD and no HardDrive the SSD is WD Blue 500 GB
And I’m using a HDMI cable to connect the monitor to the PC
 

ASK THE COMMUNITY

TRENDING THREADS