Question Choppy frames which showed up recently(GTX 1050Ti Mobile GPU)

Aug 4, 2020
3
0
10
0
Here's a small video of what I mean, showed up after I installed a second 8x RAM. Since have removed it

What I've tried so far

Reset PC/Update all drivers
Reinstall the games
Run games from HDD/SSD
Reinstalling the RAM/Changing the slots

Problem shows up on The Division, Wildlands, Warframe and CSGO. Doesn't appear on Battlefield 4 surprisingly. Here's a video to explain it better.

View: https://youtu.be/RrWCyeQxOps


PC Specs :
GTX 1050Ti 4GB
8GB HyperX Ram
1TB HDD/128GB SSD
i5 - 8300H 2.1Ghz (4.0 with Turbo)

OS : Windows 10 Home Edition

P.S All drivers have been updated, using the built in sound driver because the Realtek driver was giving me issues. No mouse drivers installed - I use Synapse 3, normally.
 
Dec 11, 2019
17
0
10
0
Does this happen only in online games?
Also you mentioned you installed another stick of ram, is it the same one as your other stick?
 
Aug 4, 2020
3
0
10
0
Does this happen only in online games?
Also you mentioned you installed another stick of ram, is it the same one as your other stick?
Happened on offline games too like Wildlands (have tested only these 3 - 4 games as of yet). My new stick of RAM is the same config - 2666Mhz 240PIN SODIMM 8GB. I swapped out the sticks for some testing but same issue still. Changed the ram slots but no change
 
Dec 11, 2019
17
0
10
0
Happened on offline games too like Wildlands (have tested only these 3 - 4 games as of yet). My new stick of RAM is the same config - 2666Mhz 240PIN SODIMM 8GB. I swapped out the sticks for some testing but same issue still. Changed the ram slots but no change
I've never seen anything like this.. So is the FPS good in games? Because to me this looks like you're having
good frame rates but you have 300 ping even though you're playing singleplayer games.

What about the monitor? Have you tried changing cables, or even using another monitor?
 
Aug 4, 2020
3
0
10
0
I've never seen anything like this.. So is the FPS good in games? Because to me this looks like you're having
good frame rates but you have 300 ping even though you're playing singleplayer games.

What about the monitor? Have you tried changing cables, or even using another monitor?
I checked out my ping on CSGO where I was getting the same issue - had 80 ping ~ 0 loss/choke and 300 fps. I've not seen a drop in FPS except the ones I normally get. I'm on a laptop ~ Predator Helios 300. Absolutely confused as to what the problem is I even tried changing the power source
 
Dec 11, 2019
17
0
10
0
I checked out my ping on CSGO where I was getting the same issue - had 80 ping ~ 0 loss/choke and 300 fps. I've not seen a drop in FPS except the ones I normally get. I'm on a laptop ~ Predator Helios 300. Absolutely confused as to what the problem is I even tried changing the power source
Since you're on laptop I assume you're using WiFi. Can you try using Ethernet cable directly from your router?
Try it again then and lmk what happens
 

ASK THE COMMUNITY