Question Choppy Performance Athlon 200GE while using general applications like browser, file explorer

May 8, 2019
2
0
10
0
Hello,

I upgraded my old PC with new Athlon 200GE, 16gb 3000 one stick and b350 GB motherboard. No graphic card. Windows 10 home installed in old SSD but intel one.
Also, I am using a 4K 28 inch monitor, which is pretty cool.

My problem is that an application performance like chrome or office application is pretty poor. There is a noticeable lags whenever loading something or showing outputs on them.
When I click window menu button, the menu pops up with little bit of lag. Overall, it is usable but reminds me of netbook when compared to my i5 8300h laptop, currently connected to same monitor.

Is this normal because it is low tier CPU? There is anyone on same CPU and please let me know how you feel on it.


Thanks
Jon
 
No, the performance should be pretty snappy. The 200ge can even do some light e-sports games at 720p or even 1080p in really old titles.
I would make sure the OS install is fresh. If it isn't, I would reinstall the os.
Make sure ram is running at 3000mhz
I would see what clocks the CPU is running at.
Are drivers updated?
 
May 8, 2019
2
0
10
0
Thank you for an advise. Ya, it was fresh OS install. Driver/BIOS were updated.
Gaming performance is pretty good, League of legends runs pretty well but chrome or file explorer is getting bit slow sometime.

Duo is that faster than single RAM? I might try next month.

I can see difference when I switched from laptop to desktop.
 

ASK THE COMMUNITY

TRENDING THREADS