Question Chromebook won't connect to Wifi after Router underwent firmware upgrade ?

Nov 8, 2020
1
0
10
0
This is a very strange issue.
My HP Chromebook was working fine with TP Link Router (Archer C6) until a firmware upgrade on the Router broke their marriage.
The Wifi signal from my Router still shows up on my Chromebook but on trying to connect, it throws error "Out of Range".

Strange thing is, the Chromebook would connect to other Wifi networks (I tried a mobile hot spot and another Router from a friend).
Stranger thing is, I could connect other devices to my router's Wifi network without any issue (I connected Mobiles, Tab and even another Laptop).
It is just and just my Chromebook Laptop that would not connect to my TP Link Router's Wifi.

Both products are within warranty, however..
When I contact HP Chromebook Support, upon learning that the Chromebook could connect to other Wifi networks, they put the blame on the TP Link Router.
When I contact TP Link Support, upon learning I could connect other devices to the router's Wifi network, they put the blame on the Chromebook.

I tried resetting router to Factory Settings but that merely defaults the configuration setting and does not remove the upgraded Firmware.
I tried resetting the Chromebook (powerwash) but the issue persists. My last seems option to be buying a new router.
Can anybody help please?
 

RealBeast

Titan
Moderator
Not sure where the setting is in a Chromebook, but in a Windows laptop you need to go into the Network control panel, manage wireless networks, and delete the old network. Then restart, find the "new" network and enter the settings.
 

kanewolf

Titan
Moderator
It is also possible that the router chose a WIFI channel that the Chromebook doesn't support. Verify that the router is not selecting channel 13 on 2.4Ghz or a DFS channel on 5Ghz. You can change the channel selection to manual and select channels 1, 6, 11 for 2.4Ghz and a channel less than 50 for 5Ghz.
 

ASK THE COMMUNITY

TRENDING THREADS