Question Cisco/FRR(Quagga) GRE Tunnel Speed Issue MTU/MSS?

rmiller66

Distinguished
Aug 27, 2011
9
0
18,510
Greetings!
I have a Cisco 2800 Series Router connected to a cable modem this, in turn connects via a plain GRE tunnel to a cloud instance and on to the internet.

The tunnel and endpoints are up and running. Traffic flows in both directions and routes properly. I have a 400 mb/s pipe at the cisco end and a much larger one at the cloud instance end. I was using LISP before in a similar situation and was getting 300+ mb/s. With the new setup I am down to 50 mb/s. I MUST have a misconfig issue someplace. I have checked CPU load on the router (<30%) and nload on the Linux Instance (Centos 7) shows the 50 mb/s with essentially zero CPU load.

I have calculated and deployed an MTU of 1476 for the Tunnel and 1436 as the MSS on both sides. (Client machines are still at 1500 default)

My basic configs are:

Cisco Router (Abridged for clarity)

ip cef
no ipv6 cef

ip tcp path-mtu-discovery
no ip ftp passive
ip scp server enable
bridge irb

interface Tunnel0
bandwidth inherit
ip address 192.0.2.2 255.255.255.252
ip mtu 1476
ip tcp adjust-mss 1436
tunnel source 68.x.x.x
tunnel destination 176.x.x.x
tunnel path-mtu-discovery
tunnel bandwidth transmit 10000000
tunnel bandwidth receive 10000000
!
interface GigabitEthernet0/0
description connection to CableModem
ip address dhcp
duplex auto
speed auto
!
interface GigabitEthernet0/1
description Connection to 24-port unmanaged switch 201 LAN
ip address 201.x.x.x 255.255.255.0
ip tcp adjust-mss 1400
duplex auto
speed auto
no mop enabled

ip route 0.0.0.0 128.0.0.0 Tunnel0
ip route 128.0.0.0 128.0.0.0 Tunnel0
ip route 176.x.x.x 255.255.255.255 68.x.x.x

control-plane
bridge 1 protocol ieee
bridge 1 route ip

scheduler allocate 20000 1000
end


The IPCFG_ETH0 on the Instance Centos 7 Box

MTU 1500

DEVICE="eth0"
BOOTPROTO="dhcp"
ONBOOT="yes"
TYPE="Ethernet"
NM_CONTROLLED="no"
IPV6_AUTOCONF="yes"
IPV6INIT="yes"
NOZEROCONF="yes"
ZONE=public

The IPCFG_TUN0 on the Instance Centos 7 Box

MTU 1476

DEVICE=tun0
BOOTPROTO=none
ONBOOT=yes
TYPE=GRE
PEER_INNER_IPADDR=192.0.2.2
PEER_OUTER_IPADDR=68.x.x.x
MY_INNER_IPADDR=192.0.2.1

Bear in mind I am also using BGPD to announce a /24 publicly and routing that /24 through the Tunnel (201.x.x.x)

Any ideas??? I believe there is an MTU/MSS issue someplace, but I have not been able to diagnose this.

Many thanks for any assistance.

Rick