Cisco Switch Configuration Help

Aug 28, 2018
1
0
10
Hey Tom's Hardwarians!

I need some assistance, because this is driving me insane.
I'm trying to have my network interconnect internally. I have a Cisco Catalyst 3750G Switch, and I have Samba shares on my Linux Server and Windows Server that I need my clients to have access and connect to.

I have looked at static routing, and using extended ACLs and just normal ACLs, and so far nothing has been able to work, and I'm not sure where to go from there.

Pasted below are sections of my switch config, if anyone can help me with this, I would be eternally grateful. I have literally hit a brick wall...

Code:
vlan access-map map1 10
 action forward
 match ip address int_network
!
vlan filter map1 vlan-list 1
vlan internal allocation policy ascending
!
!
!
!
interface GigabitEthernet1/0/1
 switchport mode access
 ip access-group int_network in

interface Vlan1
 ip address 192.168.0.245 255.255.255.0
!
ip default-gateway 192.168.0.1
ip classless
ip http server
ip http secure-server
!
!
ip access-list extended int_network
 permit tcp any any
 permit udp any any

!
access-list 2 permit any
 
By default cisco switches allow traffic when there are no access lists. Access lists are used to deny or filter traffic, not grant access. You want to remove any access lists to start with.

What you are configuring few people do. Actual vlan access lists are seldom used. Most times people use normal access lists on the routed interfaces. Although this may only be a partial configuration there should be other vlan interfaces and routing should just work between them by default. There are many different models of 3750 and these are old devices so I forget but I am pretty sure all have some basic layer 3 ability.
 

TRENDING THREADS