Civilization IV : Crash-to-desktop. NEEED HELLLLP!!!

krutz_86

Distinguished
May 26, 2009
12
0
18,510
0
Hi, i had recently installed civ 4 and played it for hours. It was fun not until i reached the industrial age and crashed to dekstop. I thought that this is just a coincidence but when i ran a custom game and selected an age that is higher than renessance(spelling?) age, like modern,future, and industrial, it crashes to dekstop right after the init graphics loading. and i thought theres another way around it, when i tried to start on renessance and advance to industrial on gameplay, AGAIN it CRASHES! :fou: I tried reinstalling civ 4, but still no avail. PLS HELP! what should i do?

NOTE: my civ 4 is patched to 1.61v and just to know my rig:
Windows XP SP3
1 gig ram
ATI Radeon Powercolor HD3850 512mb
Pentium(R) IV 3.20ghz
500 watt psu

 

krutz_86

Distinguished
May 26, 2009
12
0
18,510
0
guys found this in themeparselog:

[Oct 03, 2009 - 18:26:12] Messages while processing 'Resource/Themes/Civ4.thm'

Error : Decl - ('Civ4Theme_Common.thm', Ln:401, Col:13) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Font_Size3_Italic' not found
Error : Decl - ('Civ4Theme_Common.thm', Ln:402, Col:13) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Font_Size3_BoldItalic' not found
Error : Decl - ('Civ4Theme_Common.thm', Ln:408, Col:13) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Font_Size1_Bold' not found
Error : Decl - ('Civ4Theme_Window.thm', Ln:3048, Col:9) Assignment source propertyId 'SF_CtrlTheme_Civ4_Control_Font_Size1_Bold' not found
 

daviduk109

Distinguished
Jun 12, 2008
239
0
18,710
9
Are you playing standard civ4 or modded?

have you done anything to computer in the past that might affect things?

have you had any other problems with computer running any other games/programs?

have you tried patching civ4 to the latest version? (I believe latest patch is v1.74)

I played civ4 in the past on an older pc with an nvidia graphics card (8800gt). The game played ok, though I found it a bit difficult at the higher levels of difficulty which put me off a bit. I haven't played civ4 on my newer pc with ati card 4850.

You may get more help if you post problem on a site that is dedicated to civ games e.g. civfanatics.com site.
 

krutz_86

Distinguished
May 26, 2009
12
0
18,510
0


THANK YOU FOR THE TIP!!!
ived patched my civ 4 (no expansions nor mods installed) to 1.74 and voila :D ! it solved more than just my CTD problems but also sum bugs where the cottages or farms wouldnt appear. THANKS!!!!!!!!
 
G

Guest

Guest
Hi, i had civilization 4, colonization crashing randomly. Civilization 4 and the colonization patch were torrent downloads.
I uninstalled the colonization patch, mounted the civilization 4 dvd, run the sd4hide(creates backup of registry and modifies your current registry), then intalled the colonization patch, copied the cracked colonization.exe file to the installation directory.
Now Colonization is fine, no crashes any more.
I still have the modified registry.
 

Similar threads


TRENDING THREADS