Question Click sound from PSU

Oct 6, 2020
3
0
10
0
My power supply make one click sound when I attempt to turn on my computer. My computer will not boot.

Just finished building my entire pc. All wires are good. Everything is connected. The brought over my 4 sticks of ram from my old build and my 650W PSU from my old build as well. Both of these pieces of hardware should be fully functional. I read online that it may be a case of the motherboard shorting so I took it all apart and raised the stand screws and put it all together again and same thing. I know there's power to my board because the RAM lights up when I switch the I/O switch. Just won't turn on.

Any help or potential troubleshooting would be much appreciated.

SPECS:
MOBO: X570 AORUS XTREME
CPU: Ryzen 9 3950x
GPU: MSI RTX 2070
RAM: 4x Corsair Vengeance RGB PRO (32GB - 3200)
CASE: Corsair 680x Crystal Series
 
Last edited by a moderator:

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Make and model of the PSU? How old is it? What were the specs for your older system? Breadboard the system with only the bare minimum parts to see if you get display/POST/BIOS splash screen.
 
Reactions: TearSoaked
Oct 6, 2020
3
0
10
0
Right, knew I was missing a part. I built my last system a year ago. The PSU and RAM were bought knew for that system. I accidentally bricked my motherboard while flashing it so that's why I made a new one but I imagine the ram and psu should be fine. I'll look into breadboarding when I can thank you.

PSU: RM650X
 
Oct 6, 2020
3
0
10
0
Welcome to the forums, newcomer!

Make and model of the PSU? How old is it? What were the specs for your older system? Breadboard the system with only the bare minimum parts to see if you get display/POST/BIOS splash screen.

^ my bad, didn't 'reply'
 

ASK THE COMMUNITY