Clicking Noise? asRock Z77 Extreme 4

waterise

Honorable
Jun 21, 2013
240
0
10,690
2
I've had my PC for 2 years this August.
I finally decided to clean it out and there was dust on the Hyper 212 Evo Cooler like no other, along with the other fan and all over the PC inside. I cleaned it out, but now I'm getting this clicking noise when I plugged it all back in.

Here's the noise:
https://www.youtube.com/watch?v=PhnBl3Sk_zo

Ideas? Thanks!
 

waterise

Honorable
Jun 21, 2013
240
0
10,690
2
Well...I thought it was one of the fans, but the noise is coming directly from around the CPU Cooler fan. But I put everything EXACTLY how I had it before. All I did with the cooler fan was take the plastic fan part off to clean it, then snapped it back onto the metal part of it (I forget the terminology, sorry).
 

waterise

Honorable
Jun 21, 2013
240
0
10,690
2
Just edited post above. Sorry, on mobile.

Yeah, it never made noise like that before.
Fans are spinning fine, nothing rubbing.


Here's another video. Prolly much better one.
http://youtu.be/PhnBl3Sk_zo


EDIT:
Here's me moving the fan up-and-down slightly. It makes the same noise so it's gotta be this Cooler fan. But it never did this before. It must be moving out-and-in while it spins standing up?
http://youtu.be/qeamP6vskh4

EDIT2: The noise is still there, but it seems the more I had my PC run (which I'm now on) it gets very faint, which is good....hmm, this is strange. Pretty normal at the moment. Wonder why it's so loud when it starts up now, but then gets fine after a couple minutes.
 

ASK THE COMMUNITY

TRENDING THREADS