[SOLVED] Clock speed stuck at 0.40 GHz while charging

Jan 21, 2020
2
0
10
0
Hello,

so I have a Lenovo ideapad 330S (Windows 10, 8 GB RAM, Intel Core i5 - 8250U 1.60 GHz) laptop that I'm super happy with, except for one thing.
While charging, my CPU clock speed gets stuck on 0.40 GHz and my laptop slows down considerably. So much that playing videos on YouTube, let alone browsing or going through the computer becomes impossible. I have tried various things from other threads, such as tweaking my power plan's settings, specificaly the "Maximum processor state". Nothing worked.
One thing I noticed though is when my battery percentage reaches around 70%, the clock speed goes back to normal.
I'm getting desperate so any help is welcome!

Thanks!
 
Hello,

so I have a Lenovo ideapad 330S (Windows 10, 8 GB RAM, Intel Core i5 - 8250U 1.60 GHz) laptop that I'm super happy with, except for one thing.
While charging, my CPU clock speed gets stuck on 0.40 GHz and my laptop slows down considerably. So much that playing videos on YouTube, let alone browsing or going through the computer becomes impossible. I have tried various things from other threads, such as tweaking my power plan's settings, specificaly the "Maximum processor state". Nothing worked.
One thing I noticed though is when my battery percentage reaches around 70%, the clock speed goes back to normal.
I'm getting desperate so any help is welcome!

Thanks!
It is a know issue on that model and other Lenovo models and according to Lenovo support, it is a feature...go figure o_O.
It has to do with the "Rapid Charging" feature on that laptop.
Go to Windows Power settings and change the default power option or create your own.
You could also use Lenovo Vantage App to disabled "Rapid Charging" and restore CPU speed while charging.
 
Reactions: annse_se
Hello,

so I have a Lenovo ideapad 330S (Windows 10, 8 GB RAM, Intel Core i5 - 8250U 1.60 GHz) laptop that I'm super happy with, except for one thing.
While charging, my CPU clock speed gets stuck on 0.40 GHz and my laptop slows down considerably. So much that playing videos on YouTube, let alone browsing or going through the computer becomes impossible. I have tried various things from other threads, such as tweaking my power plan's settings, specificaly the "Maximum processor state". Nothing worked.
One thing I noticed though is when my battery percentage reaches around 70%, the clock speed goes back to normal.
I'm getting desperate so any help is welcome!

Thanks!
It is a know issue on that model and other Lenovo models and according to Lenovo support, it is a feature...go figure o_O.
It has to do with the "Rapid Charging" feature on that laptop.
Go to Windows Power settings and change the default power option or create your own.
You could also use Lenovo Vantage App to disabled "Rapid Charging" and restore CPU speed while charging.
 
Reactions: annse_se
Jan 21, 2020
2
0
10
0
It is a know issue on that model and other Lenovo models and according to Lenovo support, it is a feature...go figure o_O.
It has to do with the "Rapid Charging" feature on that laptop.
Go to Windows Power settings and change the default power option or create your own.
You could also use Lenovo Vantage App to disabled "Rapid Charging" and restore CPU speed while charging.
It is a know issue on that model and other Lenovo models and according to Lenovo support, it is a feature...go figure o_O.
It has to do with the "Rapid Charging" feature on that laptop.
Go to Windows Power settings and change the default power option or create your own.
You could also use Lenovo Vantage App to disabled "Rapid Charging" and restore CPU speed while charging.
Thanks so much! I downloaded the Lenovo Vantage App and it works!
 

ASK THE COMMUNITY

TRENDING THREADS