Question Clock_Watchdog_Timeout Error in Freshly Installed Win10

May 19, 2020
Hi, everyone. Hope you all are doing fine. Now, here's the situation


Ryzen 3700x
Evo Hyper 212 CPU Cooler
B450 Aorus Pro Wifi
8x2 DDR4 2400 RAM
2TB HDD Seagate
RTX 2060
USB Wireless Mouse & Keyboard
Windows 10 Home Edition USB STICK ( The very first version of Windows 10. It is so old that whenever I install a fresh copy - almost every other week - it does not let me to run automatic updates. I have to go into Microsoft's website and download Windows Update Assistant and then do the updates )

Anyways, so I built this system couple months ago, not happy with the CPU Fan Spikes ( compared to my old FX-8350 - it ran very beautiful and it was very silent even with the stock cooler ) ( I did play with the CPU fan settings and I still get the Spikes , it goes on for a few seconds and then goes off every time I power on my computer and most of the time when I watch youtube videos and of course when gaming ) I decided to install ubuntu 20.04. LTS and I did with no problems. ( Now, I am no expert but I know it's a different file system I guess it's ext4 )

Anyways, so I changed my mind and I installed windows back and It got frozen. I tried over and over and over ( approximately 15 times ) and it got frozen. Here's what I have realized.
( I THINK ... )

It freezes sometimes when I plug-in or plug off a USB drive ( to install the wireless adapter so that I can download the Windows Update Assistant to get the Windows10 updates )
It ALWAYS freezes in the middle of the UPDATE process most of the time showing no error or stating nothing.

Anyways, so yesterday, I got a blue screen in the middle of the update process stating Clock_Watchdog_Timeout Error. So, I did the smartest thing I've ever done in my life and I changed the Time Settings of my computer and I saw that It was in the wrong region and the time was not showing right and I thought that I solved the problem. But the system kept freezing over and over and over again.

Then, today, I decided to use the very same Windows10 USB stick on my laptop. it's an intel processor i3 with integrated intel graphics with ubuntu 20.04 installed. And guess what. It went smooth, no problems. I was able to delete ubuntu and install Win10 and also install the updates.

Anyways, so according to google, it's either a processor problem, or an outdated driver problem or a hardware problem

My questions are;

1) Since I am posting this thread using the very same system with UBUNTU 20.04, can I eliminate the CPU problem option ? Now, I also have to tell you that as I was typing, I got some lag typing the letters but it's good now. So, may be it's a CPU issue ?

2) I do not know what to do, I'd really appreciate some help thank you ...
May 19, 2020
latest bios?
go buy a usb flash drive. download the latest windows 10 iso from microsoft website
I have already tried that more than 10 times but failed to create a bootable Win10 USB for possibly couple reasons. Anyways long story short I managed to create one yesterday. It works like a charm now

My heart will always belong to you
Thank you