Question Clocked RAM wrong and PC won't start

Sep 26, 2020
4
0
10
0
Hello all looking for help. This is my first time building a PC, a few days I installed everything it booted up 1st try and got into bios. I decided, hey since I'm already here let me change my RAM speeds to 3200 did this completely wrong even after watching tons of PC build videos 🤦‍♂️, saved and exited and shut the PC down cause I was still waiting for my Windows boot drive to finish up Should have had it done prior to starting up 🤦‍♂️. Now the the only thing happening is the motherboard has the RGB and nothing else is on.

Specs:
ASUS TUF Gaming B550-Plus
AMD Ryzen 7 3700x
Corsair Vengence Pro 16gb 3200
WD 500 GB NVMe
CoolerMaster LC240E
GameMax 850W PSU
EVGA RTX 2070 Super KO


Things I tried with the help of my brother:

  • Double checked all the wiring, he found my HD Audio was inserted improperly, other than that everything was good.
  • Took the GPU out.
  • Took both RAM out.
  • Inserted single RAM in each slot trying for both RAM sticks.
  • Cleared CMOS. Took battery out 5 minutes while holding down power button, power cord not plugged in. Left CMOS battery out overnight and jumped the CTRL.
  • Tried his Corsair CX650m with only 8 pin and 24 pin in.
  • Jumped my current battery, fans and RGB turn on. Changed my RGB setting, unplugged and set the PSU for a while and tried again with the RGB setting saved.
  • Attempted to jump motherboard with both PSU's from the PWR_SW.
What I haven't tried but will after I finish work:

  • Check the CPU for any damaged pins or scorch marks.
  • Jump my current battery with case fan attached.
  • Take the motherboard out and try jump from outside the case.
The following attempts have the same issue listed above, RGB on motherboard is the only thing on. No beeping sounds or LED's lighting up on the Q-LED.

Just trying to get opinions so if I need to buy something new, I can do so before going home. Thanks in advanced!
 

ASK THE COMMUNITY

TRENDING THREADS