Question Cloned HDD not booting - not visible in BIOS Boot Priority - RAID/AHCI?

Aug 12, 2019
2
0
10
0
Hi,

I hope someone can help me in this case, it's my 4th day im struggling with it and once I solve a problem a new one appears. I try to describe everything from the beginning.
PC-Specs:
Acer Aspire M3970(G)
BIOS: P01-A3 04/19/2011
Intel SATA Onboard Raid Controller
OS: Windows 7 Professional 64bit
Last week the PC did not boot correctly (the Win7 Logo did not appear and it reboots automatically for 2-3 times). SMART showed me warnings for the hard drive so I bought a new Seagate 3TB HDD to replace my old one (WD 1,5 TB).
First I wanted to clone the hard disk with Macrium Reflect but the new HDD didn't appear in the disk management. However, it was displayed in the BIOS.

Boot Options and Boot Priority for old one:


I updated the Intel Onboard Raid Controller drivers and the Intel RST and then the new HDD also appeared under Windows. Nevertheless, the hard disk could not be cloned with Macrium during operation (VSS errors, Error code 0, Error code 9, HDD I/O errors). I suppose because the old hard drive already had too many bad sectors. Also chkdsk c: /r didn't help.

But using bootable Macrium USB the new one was now recognized and I could clone the old one.


This is probably the first mistake I made:
I restarted the PC immediately after the cloning process to change the boot order in the BIOS. This did not work. As I already read here in the forum, I would have had to switch off and disconnect the old hard disk first.

After I had disconnected the old hard disk and connected the new one to the old port, it did not boot.

The new HDD is recognized in the BIOS but it is not selectable at "Hard Disk Drive Priority"


I then tried to repair the startup via the Win7 installation DVD.
Normally a Windows partition should be found in the system recovery options. This was not the case with me


Then I installed the above mentioned new Intel Onboard Controller drivers and I suspect that the hard disk was detected because then errors were found and repair options were displayed.


I'm sorry that it is in German. Basically it wants to repair the bootmgr and add the following Startoptions:
Name: Windows 7 Professional (recovered)
Path: Windows
Windows Device: Partition = M: (the previously C: Partition)

But this results in an error "Error at saving the Startoptions"

The next approach was to set the onboard controller from RAID to AHCI. I wanted to set the following values to "0" in the registry via the Win7 DVD:
"HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci"
"HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV"
"HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\atapi"
But these were all already at "0."

I then changed the Onboard Sata Mode from RAID to AHCI and the HDD was detected in the BIOS at "Hard Disk Drive Priority"

but the boot process still ends in the blue screen despite the appropriate registry values.

I suspect that the unrecognized HDD has to do with the onboard controller and RAID/AHCI, but I have no idea where to go from there.
Does it make sense to perform the complete cloning process again and then disconnect the old hard disk directly or do I have the same problems with RAID and AHCI as now?
I also read that AHCI must be used mandatory for hard disks > 2TB, so is there perhaps no possibility to access the cloned drive on that PC-System?
 

USAFRet

Titan
Moderator
Mar 16, 2013
111,860
1,603
154,440
18,452
Cloning is not magic.
If the source drive is not working 100%, you're just moving the problem between the two physical drives.

And for future reference:
-----------------------------
Specific steps for a successful clone operation:
-----------------------------
Verify the actual used space on the current drive is significantly below the size of the new SSD
Download and install Macrium Reflect (or Samsung Data Migration, if a Samsung SSD)
Power off
Disconnect ALL drives except the current C and the new SSD
Power up
Run the Macrium Reflect (or Samsung Data Migration)
Select ALL the partitions on the existing C drive
Click the 'Clone' button
Wait until it is done
When it finishes, power off
Disconnect ALL drives except for the new SSD
This is to allow the system to try to boot from ONLY the SSD
Swap the SATA cables around so that the new drive is connected to the same SATA port as the old drive
Power up, and verify the BIOS boot order
If good, continue the power up

It should boot from the new drive, just like the old drive.
Maybe reboot a time or two, just to make sure.

If it works, and it should, all is good.

Later, reconnect the old drive and wipe all partitions on it.
This will probably require the commandline diskpart function, and the clean command.

Ask questions if anything is unclear.
-----------------------------
 
Aug 12, 2019
2
0
10
0
Hi,

thanks for your replies.

The old HDD/OS is bootable.
But during the last ~30 starts the boot failed for about 3x initially (so in these cases it only worked after 2-3 automatic reboots).
Since I currently have no time for a complete reinstallation, I thought cloning would be the most convenient solution.

So to be clear, even if I would clone the HDD again with the correct procedure, I still will have the same problems/driver issues with AHCI/RAID?
Or is it possible that one correct executed clone procedure c a n be working?
 

ASK THE COMMUNITY