Club3D Radeon HD 7870XT overclocking problem.

Zalkard

Honorable
Aug 15, 2013
114
0
10,690
1
Hello,

When I try overclocking my GPU, I would set it to let's say 1ghz core/1.6ghz memory, and it will register it, and displays as if it is applied. GPU speeds are also shown by GPU-Z as how they should be. I then start Furmark to test the overclock, and it displays the GPU speeds exactly as how I overclocked them, but then once I take a look at GPU-Z, MSI Afterburner and even AMD Overdrive in the graphics control panel (AMD Catalyst Control Center), it displays the memory running correctly, but the GPU core clock is not going above the standard frequency (925mhz). I've set the core clock to 1ghz in both graphics control panel and MSI Afterburner, yet it isn't applying the core clock when benchmarking/playing games.

Help would be very appreciated.

-Zalkard.
 

Zalkard

Honorable
Aug 15, 2013
114
0
10,690
1


Do you mean the "AMD OverDrive" menu?
 

hybird9012

Honorable
Jan 29, 2013
441
0
10,960
69
Actually 'Graphics OverDrive'. Make sure 'Enable Graphics OverDrive' is checked when you are on that setting screen :)
 

Zalkard

Honorable
Aug 15, 2013
114
0
10,690
1

---------------------------------------------------

---------------------------------------------------
It is in Dutch so I will translate it.
The "Graphics Overdrive" as you can see, is enabled.
Under that it does display a blue circle with an explanation mark, saying (Translated) "Clock settings are only enabled when the GPU is in high performance mode."
Would this have to do with anything?
 

Zalkard

Honorable
Aug 15, 2013
114
0
10,690
1


It is set to overclocked speeds, but the overclocked frequency is not being used. The memory overclock is applied, but the core clock speed is still at 925mhz, while it was set to 1ghz.

As I said in the previous post, "Clock settings are only enabled when the GPU is in high performance mode.". Does this mean that it will not use the overclocked settings untill put in performance mode as said? And if so, how does one enable this "Performance mode".
 

hybird9012

Honorable
Jan 29, 2013
441
0
10,960
69
Right.. it will only go to that speed once you start up a game or a program that heavily utilizes the GPU. What I'd do is get GPU-Z and run it in the background.. click on the Core clock and switch it to "Max". Then it will run in the background and save the Max value of whatever preference you are looking. Sounds confusing, but in short yes, your card will be running in your overclocked setting when the demand is there. Otherwise there is no real need :)

Hope that helps :)
 

Zalkard

Honorable
Aug 15, 2013
114
0
10,690
1
I got it to run at 1ghz core/1.5ghz memory as a test, and it stayed on those speeds, and rose my Unigine Heaven 4.0 Benchmark score from about 508 to 618. Then I tried my desired speeds I was aiming for, 1.1ghz core/1.6ghz memory, I ran the benchmark, and the memory was overclocked, but after a few seconds the core clock jumped back to 925, and actually scored worst than before, having a score of 498. I'm gonna try it again, without raising the memory speeds and just the core clock, to see if it works.
 

hybird9012

Honorable
Jan 29, 2013
441
0
10,960
69
There could be something going on with your voltages, etc.. you should run stress tests. Also to keep in mind, you may have a temp limiter on your video card.. so if it gets too hot, it will start to downclock.
 

Zalkard

Honorable
Aug 15, 2013
114
0
10,690
1


I ran the Unigine Heaven 4.0 Benchmark again at 1.1ghz core/1.5ghz memory and scored 626 this time. It did stay on 1.1ghz most of the time, but it was jumping back down and back up quite a bit. Could you maybe tell me a bit more about what I could do with the voltages? I also have an aftermarket cooler on my GPU (Arctic Accelero Twin Turbo 2) and it maxed out the temperature at 59 degrees celcius at 1.1ghz. So I think temperature is not the problem.
 

hybird9012

Honorable
Jan 29, 2013
441
0
10,960
69
I don't think there is anything wrong with your card. In order to save power, etc.. you core can downclock automatically when it is not being used. GPU's most of the times aren't running at 100% for a specified extended period of time, all the time. Depending on the load it can adjust.

As for voltages, you can do it in bios or a software utility that has come with the card.. don't push it up very high because it will get hot, but do little by little and stress test to see it's stability.
 

Zalkard

Honorable
Aug 15, 2013
114
0
10,690
1
I looked up into stuff about voltage. Turns out there was something called a power limit in the Catalyst Control Center. I turned it up to 10%, ran the benchmark and it stayed on the overclock I wanted 100% of the time! :) I increased my max score of 626 to 866 on Unigine Heaven 4.0 Benchmark.
 

Similar threads