CMD commands not working

Status
Not open for further replies.

skogis91

Distinguished
Mar 9, 2011
3
0
18,510
0
Hello, when I type a command in the CMD I get a message saying that the command is not recognized as a internal, external etc.

I've searched online for some answers and PATH seems to be the problem for most people. I have done PATH in CMD and C:\Windows\System32 is in there. Here's the output that from PATH:

PATH=C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program File
s (x86)\Common Files\Microsoft Shared\Windows Live;C:\Windows\system32;C:\Window
s;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Progra
m Files (x86)\ATI Technologies\ATI.ACE\Core-Static;C:\Program Files (x86)\Window
s Live\Shared;C:\Program Files (x86)\QuickTime\QTSystem\;C:\Tcl\bin;C:\Program F
iles (x86)\Nmap

I can see ping.exe in the folder to so I'm at a loss here.
Any ideas?

Regards
Eric
 

hang-the-9

Titan
Moderator
So ping does not work? Type the command exactly how you are typing it in the command prompt window. How are you starting the CMD window? Batch file, or typing it in manually? Are you starting it from a network homepath? What is the prompt you get in the window, is it "C:\>"?

Have you tried any other commads? DIR, IPCONFIG and such work or same message?
 

skogis91

Distinguished
Mar 9, 2011
3
0
18,510
0


Yes sorry should have clarified that PING, IPCONFIG even HELP doesn't work. When I type in DIR it gives me the underlying folders, so it seems to work.

To start CMD I go to start--->run-->cmd then enter. The prompt says C:\Users\PackardBell
 

hang-the-9

Titan
Moderator
In the prompt, type in C: hit enter. Then try the commands, do they work then?

You do have the correct PATH listings. Can you type in the full path to the commands and do they run properly then? Say "C:\Windows\System32\ping"
 

shubham9494

Honorable
Dec 10, 2012
2
0
10,510
0
Hello, when I type a command in the CMD I get a message saying that the command is not recognized as a internal, external etc.
for eg help pc give above error
but i open command prompt with administrator then its work what to do
 

kenrivers

Illustrious
Moderator
To make sure the path is correct in Environment variables try the following:
1. Click on Start
2. Right click on Computer
3. Click on Properties
4. Click on Advanced System Settings
5. Click on Environment Variables
6. Under System variables scroll down until you see Path
What do you see to the right of Path?

After you type in cmd and before pressing enter you could try right clicking on cmd (after it appears in the list) and selecting "Run as administrator" to see if that makes a difference. If the commands still do not run then there is a problem with the path.
 

AlmightyHB

Honorable
May 2, 2013
1
0
10,510
0
kenrivers, i see C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Users\Recipient\AppData\Local\Smartbar\Application\
 

zBurnThat

Honorable
Aug 21, 2013
4
0
10,510
0
Change to: C:\Windows\System32\
This worked for me however it may not if you have more than one hard drive. In that case go through them typing in that same address but change the "C" to what it's called. You can find out the drive name by going into Start Menu > Computer
It will say something like Drive2(U:)
 

zBurnThat

Honorable
Aug 21, 2013
4
0
10,510
0
Oops the last thing came up as a smile. I meant to write (U: ) but there's no space inbetween the colon and close bracket ")"
 

tomahawx05

Honorable
Dec 17, 2013
15
0
10,510
0
Call me stupid, but have you tried running as an admin by right clicking and running as administrator, this worked for me, if you open using run you may need to find the file location because i don't think you can run as admin using run. when i had this problem only specific commands worked so that's what made me think you have this problem, that's all i can think of that hasn't been said so far.
 

erljan cuizon

Reputable
Feb 23, 2014
1
0
4,510
0
right click in computer, select properties, left click system protection, now select advanced tab under system properties and click environment variables. click new, variable name is Path and variable value is your system32 in your drive C:

should be like this : C:\Windows\System32
now click ok..


i hope this would work in your system.
 

BenjaminDV

Reputable
Apr 22, 2014
1
0
4,510
0
I had this problem too. Changing the PATH variable to E:\Windows\System32\ seems to have fixed it. I also have a few other values, like for the Java JDK. So I didn't delete all the other values, just added the one stated previously, seperating different values with a semicolin.
 

Mohammed-Abdullah

Reputable
Oct 4, 2014
1
0
4,510
0
hhhh I like ur comment when u started with call me stupid >>> actually u r the smartest one cz ur solution the only one worked with me >>> thanks a lot

 

gmanon

Reputable
Apr 18, 2015
1
0
4,510
0
Microsoft seems to be taking security seriously.
I noticed this myself when trying to run xampp and some other programs, even eclipse, but at the same time, I noticed my computer feels more stable.

There are also less conflicts between 64 and 32 bit software.
 
Status
Not open for further replies.

Similar threads


TRENDING THREADS