[SOLVED] Code 38 on Mass Storage Device, possibly a chipset driver problem ?

Feb 5, 2022
I have a home built PC that's a couple years old with a new problem that I think I've sourced to the motherboard. here's the important thing's in the build:

MSI Z-390-A-PRO motherboard
RTX 2070 super
Intel i5-9600k

The problem: On startup, I can plug a USB or SD card into any port on my computer fine, but ejecting the device and plugging it back in causes "code 38" to appear.
What I've tried: I've gone through just about every possible fix I found online for the problem including:
  • Holding shift on shutdown
  • uninstalling driver for Mass Storage device and restarting computer
  • uninstalling both Intel's host controller and Nvidia's host controllers and restarted
  • updated bios
  • Downloaded intel's driver support assistant to update drivers
  • tried USB stick in other computers, it works fine
  • Ran troubleshooter, had to go through command prompt due to windows removing the hardware troubleshooter option
  • cleared registry issues with ccleaner
My theory: The only thing left I can think of is the chipset drivers. The problem happened when I tried to use Dragon Center to update my drivers, but the newer 2.0 version of DC didn't uninstall my old 1.0 version. After uninstalling both versions I reinstalled the 2.0 version. At some point the chipset drivers were installed to the 'latest' version. However the date for the installed chipset driver is 7/18/1968. The version is (EDIT: the driver version available on MSI's website is 10.1.18508.8239, I can't get it to properly update)

I tried going through Intel's website to get the chipset drivers to maybe rollback the chipset, but it gave me a "Management Engine Driver" instead, here's the URL: https://www.intel.com/content/www/us/en/products/sku/133293/intel-z390-chipset/downloads.html

This gave me a couple folders, and I don't know what any of them mean. There's are folders labeled "Cons" and "Corp", not sure which to choose or if I'm even in the right place. I also tried going through MSI's website to download the latest drivers, which I did and installed, but the driver date in device manager hasn't changed.

What I think I need help with? The only thing I can think of left to do would be to use device manager to uninstall the chipset drivers and then restart the computer, but would that be okay? How do you thoroughly reinstall chipset drivers? Looking for any and all possible solutions.
Feb 5, 2022