Question COMCTL32.dll was not found error after latest windows update

Jhess56

Commendable
May 20, 2020
3
0
1,510
0
Updating this with the solution in case it helps someone else searching for help with a similar problem:

I ran the sfc check a couple more times, the dism, then the sfc a final time and I'm back to normal.

I never would have thought things like that would need more than one run until someone on a fb group mentioned it.

--------------

I'm getting this error when opening various programs after updating the latest windows updates:

The code execution cannot proceed because C:\Windows\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.19041.1110_none_a8625c1886757984\COMCTL32.dll was not found. Reinstalling the program may fix this problem.

I can open images, pdfs, regular notepad, and folders, and some programs...but i cant open some programs such as ccleaner or notepad++...I get that error above about the comctl32.dll

I can open chrome and ghostbrowser and navigate around the internet just fine

I found COMCTL32.dll in my main system32 and C:\Windows\SysWOW64 folders....but it is missing from the noted folder in the error.

I've tried dragging as well as copy/pasting the file from those folders (as well as a newly downloaded replacement file) into the folder thats missing the file...but it tells me 'you need permission to perform this action)

I've tried opening file explorer with admin priveleges and going into the folder that way and tried running different cmd codes to let me access it, and my user says i have full owner access to the folder, so I dunno how to fix that so I can put the file in there?

I tried opening cmd with admin access and used this command line takeown /f <C:\Windows\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.19041.1110_none_a8625c1886757984> /r /d y but it tells me 'access is denied'

I am currently fully updated with all windows updates...this problem started after making the latest update...I tried uninstalling them and restoring to a previous point but that didnt help

I did a full scan with malwarebytes pro and microsofts tool and nothing came up

I ran check/scan disk and the dism thing and I see an error 23 message...the scans i ran said there were some problem files that it was not able to fix.

If it helps, earlier I was getting this other error when trying to open the problematic programs "the application was unable to start correctly (0xc0000142) click ok to close the application." but it was replaced by the comctl32.dll one after I got done trying to run all the checks and fixes and reverts etc.

Windows Resource Protection found corrupt files but was unable to fix some of them.
For online repairs, details are included in the CBS log file located at
windir\Logs\CBS\CBS.log. For example C:\Windows\Logs\CBS\CBS.log. For offline
repairs, details are included in the log file provided by the /OFFLOGFILE flag.

I dont see an option to attach the text file of the log, I do see errors referenced in it about not being able to repair the comctl32.dll but I have no idea what to do with any of the info

Thanks for any help
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS