Question Complicated SSD/possible motherboard issue; NVME SSD not detected in Windows or Disk Management

Jan 11, 2020
1
0
10
0
I recently built a custom gaming desktop (specs below) and I've run into an absolutely baffling issue.

Setup: my PC has 2 identical Nvme SSD drives in it. The C: drive contains the OS and all installed programs. The D: drive contains all my music/pictures/documents/downloads, as in, I rerouted the default pathways for those windows shortcuts to the D: drive. This setup had been working fine for about 2 months.

Problem: On Thursday, 1/2/2020, I was using the PC and had been for several hours without incident, when I went to open some files in my D: drive. Windows explorer hung up and eventually just crashed. I decided to restart the computer. However, it hangs up on the restart screen ("restarting" with spinny circle), and does nothing for about 10 minutes.

I forcibly restart the PC with the power button. Then it hung up on the boot screen (POST worked fine, can go into BIOS no problem, but won't boot). After several failed attempts to boot, it goes in to "preparing automatic repair" but hangs up on that as well and fails to either boot or start repair.

I'm able to fix this issue by disabling quick boot in BIOS. Computer boots as normal. But upon checking my files, I see that my D: drive is completely missing--not showing up in windows explorer OR in disk management. Just not there at all. I reboot to check BIOS, and BIOS detects both SSDs just fine. Using shift+restart and clicking "use device" ALSO shows both SSDs.

Checking Device Manager reveals that one of the two NVME controllers has a code 10 error (can not start). Drivers are updated, checked and double checked. I try uninstalling the device and scanning for hardware changes. Lo and behold, the D: drive appears in windows explorer. HOWEVER, any attempt to browse to that drive, either directly or accessing any files from that drive, results in windows explorer hanging up and eventually crashing. Attemping to restart it in task manager results in a "not responding" error. This whole process is reproduceable every time.

At this point, a cascading series of errors--related or unrelated, I don't know--crop up. Suddenly I'm unable to log into windows with my PIN (a reproduceable "we can't find your PIN" error) and I'm forced to use my MS account password to log in. This seems to screw with a bunch of local permissions, which results in, among other things, sound services refusing to start.

So at this point, I try a system restore to a restore point 5 days previous. No change. Even the PIN login error persists.

With this issue now well beyond my abilities, I take the PC to a local tech. He recommends a complete wipe of the C: drive and a fresh install of windows. He does so--AND THE NMVE CONTROLLER CODE 10 ERROR PERSISTS! Still both drives detected in BIOS. Still both drives visible when selecting boot device after shift+restart. Still crashes windows explorer upon uninstalling the NVME controller and scanning for hardware changes (which still makes the drive appear in windows explorer).

We then try to see if perhaps something is wrong with the slot. My motherboard has 3 NVME slots--and M2M, M2A, and M2P. The C: drive (the working one with the OS on it) was in the M2P slot, and the D: drive was in the M2A slot. We tried removing the D: drive and putting the C: drive in the M2A slot. We changed the boot order in BIOS and started it up. No boot. Black screen after the motherboard screen comes up.

The last thing I tried was flashing my BIOS. I was able to successfully update to a more recent version. No changes. At this point, both the tech and I were at our wits' end.



Our current hypothesis: the M2A slot in the motherboard has failed...partially. No idea what kind of failure allows for the inconsistent behavior described above, though.

Secondary hypothesis: a recent windows update broke NMVE controllers. It wouldn't be the first time, if I recall correctly. No idea how to test this, though.

I do plan to test the SSD itself when my USB NVME reader arrives in a few days. Until then, there's no way for me to test it directly.



System specs:

Motherboard: Gigabyte Z390 Aorus Master (BIOS updated today to version F11c)

CPU: Intel Core i9-9900KF

SSDs: 2 Kingston 1TB A2000 M.2 2280 Nvme SSD PCIe

RAM: 32 GB (4 x 8GB) G.Skill Ripjaws V series DDR4 3200MHz

GPU: NVIDIA GeForce RTX 2080 Ti

OS: Windows 10 64bit Pro, version 1909

Please ask if you need any further information. I would greatly appreciate any help, as this issue is beyond me.

P.S. The PC itself has not been damaged or jostled in any way. It has sat safely under my desk for about 2 months, unmoved. The case has excellent airflow and I regularly wipe dust from the fan grates on the outside of the case.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS