Question Computer beeps endlessly without ram, gives no beep with ram installed.

Jul 1, 2021
3
0
10
0
as the title suggests, my pc just keeps beeping with no ram installed but wont give a beep code when they are installed. All the fans including the cpu fan turn on, tested my PSU on another system aswell as my GPU, they both still work. My MOBO is brand new because my last one got fried somehow, this happened after i plugged my vdg cable in the LED_c1 pins (stupid mistake i know). I also want to add that both my cpu and ram were present in the MOBO at that time now i just want to know which of these is dead?

SPECS
MOBO: gigabyte z490m GAMING X
PSU: Corsair VS550
CPU: Intel I7 10700K
GPU: Geforce 1050 TI
RAM : G.skill DDR4 Aegis 3200Mhz (x2)
 
Jul 1, 2021
3
0
10
0
take the gpu out and test with igpu.

got another psu for testing?
hi, i used a seasonic M12 II Evo 620W this time and the igpu as you said, still the same outcome though, everything turns on, it gives continuous long beeps without my ram but doesn’t do anything with them
 
Jul 1, 2021
3
0
10
0
was it working before?
what connection are you using for the monitor? dp/hdmi?
Im using hdmi and yes it was working when i had my other MOBO which was a gigabyte z490m, until i plugged in that vdg cable of course which might have caused a short circuit or something, i also remember vaguely smelling something burnt back then. This is why i went to get a new MOBO but im worried my cpu or ram might’ve still been damaged
 
Last edited:

ASK THE COMMUNITY