Question Computer BSOD when using Silicon Power P34A60

Aug 7, 2022
3
0
10
0
I recently built a computer with the following specs:
  • AMD Ryzen 5 5600G 3.9 GHz 6-Core Processor
  • MSI B550M PRO-VDH WIFI Micro ATX AM4 Motherboard
  • Silicon Power GAMING 16 GB (2 x 8 GB) DDR4-3000 CL16 Memory
  • Seagate Barracuda Compute 2 TB 3.5" 7200RPM Internal Hard Drive
  • Silicon Power P34A60 512 GB M.2-2280 NVME Solid State Drive
  • Gigabyte GeForce RTX 3060 12 GB EAGLE OC Rev 2.0 Video Card
  • EVGA SuperNOVA GA 650 W 80+ Gold Certified Fully Modular ATX Power Supply
The underlined Silicon Power P34A60 is the issue. When I built the computer, it wouldn't get past the "getting devices ready" section so I assumed the SP drive was dead, ordered a replacement and temporarily swapped in a smaller SATA SSD. The new drive arrived today so I installed it, cloned the temporary SATA SSD to it, and attempted to boot with it. Now whenever I try to boot off of the new SP drive, the computer BSODs. The temporary drive that was cloned still boots fine, but the new drive will not work at all. I checked compatibly with both of my motherboard's slots and tried the drive in both but no dice either time. What is wrong here? Do I have an incompatible part? I'm at my wit's end trying to figure out what on earth is wrong with my drive.
 
Aug 7, 2022
3
0
10
0
Welcome to the forums, newcomer!

Can you check and see what your BIOS version for the motherboard is at this moment of time?
Thanks for your quick reply (sorry mine's a little late)! The current BIOS Version is E7C95AMS.290 and the BIOS Build Date is 12/23/2021
 

ASK THE COMMUNITY

TRENDING THREADS