• Hey there, Guest! Share your idea for a new trophy in the forums and win bragging rights and a $100 Amazon gift card! Check out the New Community Trophy Contest here!
  • Pardon our dust as we work on some regularly scheduled forum maintenance. You may notice some missing features during this time. Thank you for your patience!

Computer crashes, then can only reboot if memory is reseated.. help!


Aug 9, 2010
Hey guys,

I've been having this BSOD once everyday. I noticed it happens sometime in the evening when i sleep. When i go to use my PC after i wake up, it has already crashed. The app that i usually have running on idle during that time is Diablo.

Now here's the funny part. If i normally switch my PC off then on, it doesnt boot. I havent really tried any other way to make it start but the first thing that worked was if i reseated my memory, ie. if I take one piece of memory out and then immediately then turn it on it will work 100% of the time (i have 2x 2GB kingston ddr3 1333mhz ram).

I hate that I have this "reoccurring problem with reoccurring solution." Much like how you kick the engine of your car if it wont start kind of thing...

Would like to know if you guys can diagnose my problem any further... Thanks!

Some impt. questions and facts:
1) Does it mean it's really my memory? Like a memory fault error thing?
2) None of my PC parts are overclocked and therefore are running at their normal timings and voltages.
3) My pertinent components are Phenom2 945 3.0Ghz, MSI 870-G45 mobo, 2x2GB Kingston DDR3 1333mhz ram, Samsung Spinpoint F3 1TB HDD, Inno3D Geforce GTS450 (nvidia 301.42 drivers), Silverstone ST-50F 500W PSU.
4) I have an inkling it could also be my GPU or its drivers because one BSOD happened when after I was playing Diablo for around 5 hours straight without any problems then my screen stuttered for about 2 seconds then I BSOD'd.



It helps when u do some changes in the BIOS and than u may have some older setting there that don't play nicely anymore, or maybe you did some HW changes that didn't registered properly.

In any way it will set it to the default and than I know this and I can focus on another problem in line.

Sometimes, it is enough when u add more RAM and it wont work and reset will fixed that with out any issues.



Oct 31, 2012
Sorry to bump such an old thread but I am having the exact same problem. I just reset my cmos but I am still having the same problem. Any advice?

OS: Windows 7 64 bit
Graphics:GeForce 9800 GT 512MB 256-bit GDDR3
Motherboard:MSI 770-G45 AM3 AMD 770 ATX AMD
CPU:AMD Athlon II x3 445 3.1Ghz
RAM:G.SKILL Ripjaws Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600
PSU:Antec NeoPower 550W

Similar threads