Question Computer Crashes with new WiFi Adapter

Jul 2, 2019
22
0
10
0
So I just completed a new budget build, not sure what information is required to help diagnose my issue but its a Gigabyte B40M board, Ryzen 5 2600X CPU. Powersupply is a 650W Bronze Rated. Netgear USB WiFi adapter Model: A7000 (AC1900)
I had an old WiFi adapter laying around that I was using until I bought this one a few days ago, which worked fine (and does now) When I installed the hardware first online (don't have a CD-ROM drive) I made sure I installed the right drivers. Plugged in the WiFi adapter, everything worked fine. I did a speed test and my speed significantly improved. It was fine for 2+ hours, then all of a sudden my wireless connection dropped, couldn't diagnose connection or do much the computer just basically stopped responding. Then I got a blue screen UNEXPECTED_KERNEL_MODE_TRAP . Restarted it, connected fine again, then another disconnect maybe 10 minutes later with the same exact blue screen. When I unplugged it, and plugged in my old WiFi adapter everything works fine. I only tried plugging it in to the front USB port, i'm not sure if it would be worth plugging it directly into the USB port on the board, if that somehow could make any difference? Any other insight is much appreciated, and if you need any other info please dont hesitate to ask!

Thanks!
 
If it's a usb wireless adapter, try using a usb 2.0 insead of 3.0 and vice versa. If captains solid advice doesn't work try that then also try installing updated USB drivers because those ports are what is used for the adapter.
 

ASK THE COMMUNITY

TRENDING THREADS