Question Computer doesn't work anymore

Mar 31, 2019
3
0
10
0
So I decided to finally upgrade my computer from an AMD FX6300 to Intel i7-6700K. My friend upgraded his computer recently and gave me his unwanted parts, an I7-6700K CPU and an Asus Z170-e motherboard. I bought new 16GB RAM(2 x 8GB sticks) a new heat sink, Corsair H60 and installed all these parts in my tower.

The computer worked just fine for about a week or two and then in the middle of playing a game, Risk of Rain 2 btw, my computer froze and then died. I tried turning it back on but the computer would not boot. The fans turn on, the lights all turn on but nothing shows on my monitor. The red CPU light is on so i assumed there was something wrong with it so I took it out to check the pins, no bent pins. Then i reseated the CPU, installed the heatsink again and the cpu light still comes on with nothing on my screen again. I've tried a lot of things i've found while googling around for and answer but none worked so far.

What I've tried:

- Re seating CPU
  • Checking Pins
  • Checking all connectors are in properly
  • Different RAM variations, Single, duo, new RAM, different slot, cleaning out the slots
  • Taking out GPU and connecting monitor to onboard video
  • Clearing BIOS
Nothing worked so I installed my old parts, AMD FX 6300 and the computer works just fine. So I'm assuming its a Motherboard or CPU issue. Any thoughts?
Again the computer was working just fine with the new parts for about 2 weeks and died in the middle of a game.

My specs:
CPU - i7-6700K (non Over clocked)
MOBO - Asus Z170-e
PSU - 650W 80+ Bronze
RAM - Corsair Vengence RGB Pro 16GB 2 x 8GB
Cooler - Corsair H60
GPU - Asus Strix GTX 970

Sorry if this was a little long.
 
Mar 31, 2019
8
0
10
0
Sounds like a psu problem. Your cpu must be running full mid-game and your psu might not be powerful enough.
 
Mar 31, 2019
3
0
10
0
Whoops sorry my PSU is Actually EVGA NEX 750b 80+ Bronze.

Yes i tried the most minimal setup with just the mobo, cpu and just a stick of ram, with monitor connected to motherboard, and nothing is showing on screen, but all the fans and tower LEDs turn on.

Wouldn't the computer at least boot up to bios even if the psu couldnt provide enough while in game though. Or does the computer just know now that its not enough power and wont turn back on.
 
Mar 31, 2019
3
0
10
0
Okay I will probably try to buy a new motherboard and try it out. Any suggestions on New/Used boards. Not trying to spend any more than 100 or 200.
 
GIven your possible failure with the current Asus board, it seems odd to recommend another, but, I've loved my Asus Z270A Prime for 2 years now...; unfortunately, the only one I see on Amazon, seller is stupidly asking for $369....uhhh, no. (I hoped perhaps that was a CPU/MB bundle, but..no, that's a ridiculous price for a Prime board..)

I'd probably go thru Tom's Hardware and HardOCP's archives looking at their Z270 tests from 2 years ago....find one that got best ratings..
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS