Question Computer freezes at random times (No POST a lot of times)and Screen Glitches crazy! (MB: Maximus vii Hero)

Jan 22, 2020
3
0
10
0
Good Day everyone, for the past week I am wrestling with this problem where my computer would freeze suddenly in between operation and the monitor starts flickering/glitching like crazy (Sometimes my monitor even produces a crackling sound when it happens) I was able to find 2 posts with a similar problem to mine and the pics shown in that is very close to mine.

(Link 1 Link 2)

I don't believe this is a software issue since sometimes the screen glitching happens during the Bios screen and Bios configuration as well. But other times the computer works fine as usual... but every single time the screen glitching problem occurs I immediately hit the restart button and my Comp goes in a boot loop unable to even reach post. It throws around different error codes but the most common ones are 00 and A2. Where it shows 00 and then restarts again and the process keeps continuing (Red light is seen on the CPU_LED in the motherboard when it happens) until it just randomly and magically just starts functioning normally again and then suddenly the problem returns back (It's a very annoying hell hole!).

Additional note: I had a youtube video running once when the problem occurred and the music just screeched like a banshee. In other words, when the screen glitch happens, my comp processes are malfunctioning so it's not a monitor issue.

I'm an incredibly broke person trying to make ends meet and I don't have enough money to replace the entire system and I'm trying to figure out which particular part is malfunctioning so I can replace just that part. But it seems in situations like these the problem could range from a faulty PSU or a MOBO problem to my CPU + Integrated graphics malfunctioning etc.

Please throw me your suggestions.

Computer Specs: MOBO: Asus Maximus vii hero motherboard
CPU: Intel core i7 Processor (4790K) LGA-1150 (4 Cores) Supports 2 channel DDR3 Memory.
PSU: Corsair VS650 ATX Power Supply (650 watt)
RAM: HyperX Memory. 2 x 8GB DDR3 (1866 CL10 240 Pin UDIMM) Memory Module (Total 16 Gigs RAM)
FAN: Cooler master Hyper TX3 Eco (Intel LGA 1151)
SSD: Samsung SSD 850 Pro (256GB)
HDD: WD Blue 2TB (2015)
Cabinet: Cooler master 912 HAF (Micro ATX/ATX)
Monitor: Dell S2240L 21.5 inch LED Backlit (1080P,59Hz,8Bit)
DVD: GH24NSC0 Internal 24x Super Multi with M-DISC™ Support
What happens to my comp looks pretty much exactly like these images.


 

ASK THE COMMUNITY

TRENDING THREADS