Question Computer freezes suddenly when surfing on google? NO BSOD

ceejay7

Prominent
Feb 4, 2019
141
6
595
1
Hello, if anyone can help me. I have this problem that occurred 3 times now from the last few weeks.
recently my computer freezes when I click the back button of the google chrome (The last time when it was opening a new tab). I moved my mouse and no sign of movements on the cursor AND no BSOD,
I tried to restart my monitor and it showed "No Signal".. pretty weird. The computer is still running though

I restarted my PC using the restart button, booted up, checked my event viewer and it didn't showed any clues of the problem. It only showed "Kernel power something", that is thec cause of me restarting my pc.

I already stress tested my ram, cpu, gpu and HDD. It is still showing the same problem

please help.
 
Last edited:

white.a.drew

Respectable
Oct 14, 2017
726
46
2,240
55
Hello, if anyone can help me. I have this problem that occurred 3 times now from the last few weeks.
recently my computer freezes when I click the back button of the google chrome (The last time when it was opening a new tab). I moved my mouse and no sign of movements on the cursor AND no BSOD,
I tried to restart my monitor and it showed "No Signal".. pretty weird. The computer is still running though

I restarted my PC using the restart button, booted up, checked my event viewer and it didn't showed any clues of the problem. It only showed "Kernel power something", that is the
cause of me restarting my pc.

I already stress tested my ram, cpu. It is still showing the same problem

please help.
pc specs?
 

ceejay7

Prominent
Feb 4, 2019
141
6
595
1
RYZEN 5 2600
RX 5700 XT
TUF 3200 MHZ 16GB
A320 PRO VH PLUS
SEASONIC S12II 520W
TeamGroup Elite 256 SSD
WD 7200RPM 1tb HDD
 
Last edited:

white.a.drew

Respectable
Oct 14, 2017
726
46
2,240
55
RYZEN 5 2600
RX 5700 XT
TUF 3200 MHZ 16GB
A320 PRO VH PLUS
SEASONIC S12II 520W
TeamGroup Elite 256 SSD
WD 7200RPM 1tb HDD
so then i'm asumming your using Ethernet, if this is the case i would try running speedtest.net and a few other internet speed test, see if you are having a buffering issue with received signals.
 

ceejay7

Prominent
Feb 4, 2019
141
6
595
1
I guess your browser crashed, so it might be because of software related not hardware related
I hope so, I reinstalled chrome and reinstalled AdBlock extension because there is a thread saying that was the cause of their cpu going into a 100% load. I think that is also the cause of my problem. I could have waited my pc loading instead of restarting it.
 

ceejay7

Prominent
Feb 4, 2019
141
6
595
1
Recently, I was surfing normally with my youtube ON and playing music, My monitor freezed but the music was still playing so I suspect it is the monitor? before that I was playing with Overdrive settings before the freezing happened because I was doing a test on another issue.
 

ceejay7

Prominent
Feb 4, 2019
141
6
595
1
I rolled back to the 19.11.3 driver, no freezing issue. There is this latest update stating that the intermittent black screen when web surfing and gaming is fixed but it is still on the known issues side, weird.
 

ASK THE COMMUNITY

TRENDING THREADS