Question Computer Freezes when playing games with buzzing sound

Oct 11, 2019
2
1
15
0
Spec:
CPU: Intel Core i3-3220
GPU: Radeon RX560
RAM: HyperX 8GB DDR3 1333 one stick and HyperX 4GB DDR3 1333 also one
Motherboard: Asus P8B75-V

So as the title says when playing games after a random period of time the screen freezes completely with a loud buzzing sound. After I reboot the PC sometimes it does not boot at all and the DRAM LED on the motherboard lights up. Refitting the RAM makes the computer boot again, using the MemOK function of the motherboard also makes the PC boot but neither solves the problem.

I am sure the RAM is in the right slots. Moreover, everything has been fine for the past few months. I see no apparent reasons to why this is happening.

Also, I have had an "Overclocking failed" message a few times after these freezes. I am not overclocking and I assume it is because of the forced shutdown of the computer that I did when it froze.

I have run the Windows memory diagnostics tool, it has shown no errors.

If anyone knows what the problem might be or what I should try to do to fix it, please help.
 
Reactions: Jaggho

Barty1884

Titan
Moderator
Try running MemTest from a bootable USB instead:
https://www.memtest86.com/

The mismatched memory is most likely to be where the problem sits.
You may simply have to manually enter your RAM timings, as the differing modules likely have slightly different timings. Enter the looser of the two, and you should be fine - although mixing & matching memory is a bit of a crapshoot at the best of times.
 
Oct 11, 2019
2
1
15
0
Try running MemTest from a bootable USB instead:
https://www.memtest86.com/

The mismatched memory is most likely to be where the problem sits.
You may simply have to manually enter your RAM timings, as the differing modules likely have slightly different timings. Enter the looser of the two, and you should be fine - although mixing & matching memory is a bit of a crapshoot at the best of times.
I have tried removing the 4GB stick and running with only 8GB one and the problem remained. Does that exclude mismatch in memory?

Also, I have just run the MemTest twice. First time it froze on ~14th minute, second time on 3rd minute.

And lastly, where do I get these timings from?
 
Oct 11, 2019
4
0
10
0
I have the same problem with the rx 570.. After Windows october update i'm having freezer After few minutes on all my games (Apex Legends, for honor and Batman Arkham knight)... I've tried a lot of things: check RAM and hdd integrity, reinstall games, reinstall Windows, reinstall vc_redist, malware and virus Scan, update GPU driver, downgrade GPU driver, update hardware drivers (monitor, CPU, USB, audio, ecc), SFC/scannow with zero violatons, checked PSU, GPU, CPU and motherboard cable, play with less core or with max fps level, disable vsync, play in Window mode.. and other stuff.. I don't know what to do anymore.. everything I try, games freezes PC After 2-5 min.. sometimes with bsod and sometimes with a buzz audio and video freeze..

PC spec: i5 4460, 8gb ram, rx 570 4gb

Before Windows october update i've played with zero crash Batman Arkham knight at high settings at 60fps.. Also for Honor 200+hours of games without problems..
 
Oct 11, 2019
4
0
10
0
This morning i've done a stress test with AIDA64 and it told me that the TdrDelay was too low so suggested me to set it to high, and it does. The stress test finished without problems, temp stayed under 40° because i have 5 fans in the case (3 for air flow-out and 2 for air flow-in), gpu and cpu goes well, also the RAM. So i don't know wher's the problem. I will try games and let you know.

EDIT: before this test i've done a malware scan with windows malware tool and with malwerbytes: zero results.
 
Oct 11, 2019
4
0
10
0
BSOD: KMode Excpetion Not Handled, after 2 min of gameplay.

UPDATE: i've update LAN drivers, restarted and started a game (apex legends).
After 2 min during the game (not lobby) PC freeze: 2 sec with video freeze and buzz audio and then black screen + buzz audio. I'm suspceting that ther's something wrong with the amd drivers, i have the 19.9.2 and i've done yet a clean unistall with DDU in safe mode and i've installed the latest 2 drivers 19.10.1 and 19.9.2, and then 19.7.3 and 19.2.1 but nothing changed (before any install i've done a DDU clean-up).

UPDATE 2: I've done again a clean with AMD clean utility and installed 19.10.1. This time game causes BSOD for 1 sec without freeze and shotdown the PC into a reboot loop
 
Last edited:

ASK THE COMMUNITY