Computer freezing (1 month old build) - Possibly Solved Faulty PSU!!!!!


Aug 4, 2017
Hey there

Recently built a new computer as my old one started acting up and wasn't worth fixing

Computer was working great for three weeks until one day it froze while watching youtube (mouse /keyboard didn't respond). Tried ctr +alt delete, hitting reset, held down reset and in the end held the power button for 5 seconds to shut it down.

Upon restarting the computer screen was blank. Tried connecting the Dvi cable to my MOBO but still blank (graphic card was still connected at the time).
Gave up and went to MSY service center the following morning, where it booted up without any issues. Was told possibly Graphic card dying out.

Disconnected the graphic card and ran a DVI from my motherboard to my monitor and HDMI to my Tv. Computer was working great for another week Until last night I was playing Skyforge for about 7 hours and it froze on me.

Was logging temps using NZT CAM and CPU temp was at 45c during the 7 hours of skyforge
When the graphic card was connected previously it was running 55c on medium setting for GPU and CPU was at 40-41c during 3 hours of gaming.

If the computer boots without a blank screen, It freezes in bios and when I make it to windows it will freeze during 5 min of idle.

Power supply was taken from my old computer as at the time it was close to 2 month old. Should mention this happen once previously on my old computer but was under the assumption it was my ram as the motherboard code came up error 51 ( no memory detected)

While in Bios
Noticed these voltage setting on idle
+12v = +10.272v <----is that low for idle???
+5v = +4.72v
+3.3v = +3.392

Have Tried
Disconnecting /removing Graphic card
Moving hdd with windows to another sata slot / tried different cable too
Disconnecting fans that run on power supply
Tried running 1 ram in every slot (tried this to both rams)
Unable to do a ram test as it freezes (tried USB boot drive too)

Will be handing the computer to MSY service center on Monday and hopefully they can find the issue but wanted to ask what other options I can try before then.

Computer specs (about 1 month old)
Cooler master RC590
Asrock B250 k4 (mobo)
I5 7400 (cpu)
Cooler master hyper 103 cpu cooler
Kingston HyperX Fury 2400mhz (4gb X 2)
1tb WD black (2 weeks old) with fresh window 10 pro
3tb WD Black (1 year old)
3tb WD black (1.5 year old)
thermal take lite power 750w PSU (3 month old)
4x120mm deepcooler Xfan (3 run on big molex on psu, 1 runs on mobo)
2x120mm cooler master fans ( both run off mobo )
1gb gtx550ti (5 years old ) <--- Will be upgraded to Asus Strix 1060 6gb once all this is sorted.

Preiviously ran 120gb kingston SSD which was 1.5 month old from my old computer - Drive disappeared in bios and froze on the new system which was swapped for a 1tb WD black.


Aug 4, 2017
Problem Possibly Solved.

Tested the 4 pin Molex with my digital Multimeter and on Idle the 12v rail was showing 10.4v. Upon taking it to Msy service centre, they tested the PSU using their PSU tester and it failed instantly.

Was given the option of a replacement of the same PSU (ThermalTake lite 750w) or choose another and pay the difference.

Have gone with Antec True power classic 650w. Currently Playing Skyforge with my gtx550ti installed on high setting for 10 hours straight so far.

My old Thermaltake litepower 750w PSU was purchased on the 25/05/2017.