Computer Freezing and BSOD

michalis95

Honorable
Apr 11, 2012
7
0
10,510
Hello everyone, how are you?

My HP xw6400 has been running fine until the last months, it began acting strangely. At first it froze once a week, the screen just lay still and did nothing at all, the mouse didn't move nor could I turn CAPS lock on or off, nothing. The HDD LED was blinking every 5 sec and no matter what I did, I had to press the power button for 10 sec and then restart it to work. Now this is more frequent and during some power ons I get the "windows recovered from an unexpected error" the error being a BSOD which I haven't seen with my own eyes.
Last week the monitor stuck, all was black except where my mouse went. I had to press the desktop button for my pc to show up everything

Weird thing is that I get the errors without doing something certain (ex: photoshop) they just pop up twice a day or more. I can't replicate the error

PC SPECS:
Intel Xeon E5320 1.86 Ghz Quad Core
2 HDD running on RAID 0
2 GB of HP DDR-2 667 MHz ECC OEM memory
Nvidia GT 220 as primary on 2 monitors
Nvidia 8600 GTX on 3rd monitor


I am new to the forum so please bear with me. Can anyone suggest anything?

Thanks,
Michalis95
 
my first thought is powersupply
that computer is close to 5 years old and if you are running the stock 575watt
which was just meant for a stock setup but you have two HDs and two video cards
then that would be the first suspect
if you get 5 years of life from a OEM PSU then you are already pushing the limits especially if running more hardware than the computer was originally spec'd for

if you can borrow a PSU or can afford to replace it that would be my first step

and really doing BIOS updates are good but only if really needed
you are taking a chance of bricking the computer if the power goes out during an update
also a bios update on a computer that is freezing is a really BAD idea
if it freezes during update you have an expensive paper weight
 

michalis95

Honorable
Apr 11, 2012
7
0
10,510
Hello, thanks for the reply

I'll try changing the power supply today, see if it works.
Can it be corruption of one of my HDD's?