[SOLVED] Computer hangs for a few seconds and turns off randomly?!

Arsalan_1

Reputable
Feb 16, 2016
3
0
4,510
0
I am having a problem with my computer once a day while I am randomly surfing the internet or doing some other non intensive task the PC hangs for a few seconds and then shuts off, but the CPU cooler + another fan keep on spinning and the GPU light also starts blinking.

Once I restart it, it works perfectly normally.

I play a few games, temps go to around 60c - 65c but that doesn't trigger it. When this problem occurs the temps are usually around 38c - 44c.

Component list:
  • Ryzen 2600 - (NEW)
  • MSI A320M-A Pro M2 - (NEW)
  • Strix RX470
  • Gigabyte 650w 80+ Bronze PSU - (NEW)
  • 16gb (8x2) RAM - (NEW)
  • 1tb HDD & 500gb SSD
Any suggestions or solutions will be appreciated, this has been driving me mad for weeks now!
TIA
 
I am having a problem with my computer once a day while I am randomly surfing the internet or doing some other non intensive task the PC hangs for a few seconds and then shuts off, but the CPU cooler + another fan keep on spinning and the GPU light also starts blinking.

Once I restart it, it works perfectly normally.

I play a few games, temps go to around 60c - 65c but that doesn't trigger it. When this problem occurs the temps are usually around 38c - 44c.

Component list:
  • Ryzen 2600 - (NEW)
  • MSI A320M-A Pro M2 - (NEW)
  • Strix RX470
  • Gigabyte 650w 80+ Bronze PSU - (NEW)
  • 16gb (8x2) RAM - (NEW)
  • 1tb HDD & 500gb SSD
Any suggestions or solutions will be appreciated, this has been driving me mad for weeks now!
TIA

Run a memory test for at least an hour or two to make sure your ram is good.
Run Prime 95 or another CPU stability test to check for errors.
Download and run the disk utility from whatever make of HHD and SSD you bought to check drive health.
Download HWiNFO64 and monitor your voltages to make sure the power supply is providing good voltage.
Do a clean install of Windows.

If all of those tests are OK, and you're still getting errors after the Windows re-install, then I would replace the motherboard with a higher quality one.
 
I am having a problem with my computer once a day while I am randomly surfing the internet or doing some other non intensive task the PC hangs for a few seconds and then shuts off, but the CPU cooler + another fan keep on spinning and the GPU light also starts blinking.

Once I restart it, it works perfectly normally.

I play a few games, temps go to around 60c - 65c but that doesn't trigger it. When this problem occurs the temps are usually around 38c - 44c.

Component list:
  • Ryzen 2600 - (NEW)
  • MSI A320M-A Pro M2 - (NEW)
  • Strix RX470
  • Gigabyte 650w 80+ Bronze PSU - (NEW)
  • 16gb (8x2) RAM - (NEW)
  • 1tb HDD & 500gb SSD
Any suggestions or solutions will be appreciated, this has been driving me mad for weeks now!
TIA

Run a memory test for at least an hour or two to make sure your ram is good.
Run Prime 95 or another CPU stability test to check for errors.
Download and run the disk utility from whatever make of HHD and SSD you bought to check drive health.
Download HWiNFO64 and monitor your voltages to make sure the power supply is providing good voltage.
Do a clean install of Windows.

If all of those tests are OK, and you're still getting errors after the Windows re-install, then I would replace the motherboard with a higher quality one.
 

ASK THE COMMUNITY